Bug 735697 - guest rhel6.1 installation fails when qcow2 images size <=5G
Summary: guest rhel6.1 installation fails when qcow2 images size <=5G
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 03:29 UTC by FuXiangChun
Modified: 2011-09-07 14:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 17:44:02 UTC


Attachments (Terms of Use)
guest installation process snapshot (159.34 KB, image/png)
2011-09-05 03:30 UTC, FuXiangChun
no flags Details
anaconda log file (31.08 KB, text/plain)
2011-09-06 02:02 UTC, FuXiangChun
no flags Details
storage log file (84.76 KB, text/plain)
2011-09-06 02:02 UTC, FuXiangChun
no flags Details

Description FuXiangChun 2011-09-05 03:29:07 UTC
Description of problem:
create a 5G size qcow2 image and install guest rhel6.1, installation will fail. error message is insufficient disk space, there is a snapshot in attachment. if create a 10G size qcow2 image to install guest  and  include DeskTop package, after installation is complete, guest image actual size about 2.6G.

# du -sch rhel62-10g.qcow2 
2.6G	rhel62-10g.qcow2
2.6G	total

# qemu-img info rhel62-10g.qcow2
image: rhel62-10g.qcow2
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 2.6G
cluster_size: 65536
  

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-192.el6.x86_64
# rpm -qa|grep kvm
qemu-kvm-0.12.1.2-2.184.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.qemu-img create -f qcow2 rhel62-5g.qcow2 5G

2.# qemu-img info rhel62-5g.qcow2
image: rhel62-5g.qcow2
file format: qcow2
virtual size: 5.0G (5368709120 bytes)
disk size: 197M
cluster_size: 65536

3./usr/libexec/qemu-kvm -M pc -enable-kvm -m 4G -smp 4 -name rhel6-32 -uuid ddcbfb49-3411-1701-3c36-6bdbc00bedb9 -rtc base=utc,clock=host,driftfix=slew -boot dc -drive file=/home/rhel62-5g.qcow2,if=none,id=drive-virtio-0-1,format=qcow2,cache=none,werror=ignore,rerror=ignore -device virtio-blk-pci,drive=drive-virtio-0-1,id=virt0-0-1 -netdev tap,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:19:3b:80 -spice disable-ticketing,port=5912 -monitor stdio -cdrom RHEL6.2-Server-i386.iso

4. select DeskTop packages during installation process

  
Actual results:
installation fails

Expected results:
install successfully

Additional info:

Comment 1 FuXiangChun 2011-09-05 03:30:36 UTC
Created attachment 521425 [details]
guest installation process snapshot

Comment 2 Kevin Wolf 2011-09-05 08:36:46 UTC
Does the guest see the correct disk size, e.g. in the partitioner?

If so, this is not a qcow2 bug, but just what would happen on raw images or even real hardware, too.

Comment 3 FuXiangChun 2011-09-05 09:30:36 UTC
(In reply to comment #2)
> Does the guest see the correct disk size, e.g. in the partitioner?
> 
> If so, this is not a qcow2 bug, but just what would happen on raw images or
> even real hardware, too.

1.if image is raw format, it has the same issue.
2.use 5G size iscsi block to create 10G size qcow2 images and install guest, installation work well.

# lvscan
  ACTIVE            '/dev/test/data2' [5.00 GiB] inherit
# qemu-img info /dev/test/data2
image: /dev/test/data2
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 0
cluster_size: 65536

Comment 4 Chris Lumens 2011-09-05 19:29:39 UTC
Please attach /tmp/anaconda.log and /tmp/storage.log from during installation to this bug report.

Comment 5 FuXiangChun 2011-09-06 02:02:07 UTC
Created attachment 521558 [details]
anaconda log file

Comment 6 FuXiangChun 2011-09-06 02:02:54 UTC
Created attachment 521559 [details]
storage log file

Comment 7 David Cantrell 2011-09-06 17:44:02 UTC
5G is still not enough disk space to perform an installation using automatic partitioning and including the desktop package group.  Automatic partitioning sets up a /boot volume of 500M, the rest is then in a volume group.  The logical volumes include swap, /, and /home.

/boot and swap are created along with the other filesystems.  Installation cannot continue because your / filesystem lacks enough space.  The reason your qcow2 image is 2.6G is because of swap space being allocated and the other filesystems being allocated.

Comment 8 Kevin Wolf 2011-09-07 07:55:41 UTC
I would argue that it's a bug in the automatic partitioner if the hard disk is big enough to actually contain an installation and only the partitioning makes it impossible to fit.

Comment 9 David Cantrell 2011-09-07 14:14:05 UTC
But the user specifically requested the desktop group.  We don't look at a system and say, "ehhh, it's not really big enough for what you asked for, so we're just going to deselect some stuff so some other stuff will fit."  The error reported in the screenshot in comment #1 tells you why we can't continue.  The installation guide explains what partitions the automatic partitioning will allocate and how.


Note You need to log in before you can comment on or make changes to this bug.