Bug 735731 - UI throws an error while editing the repo's URL
Summary: UI throws an error while editing the repo's URL
Keywords:
Status: CLOSED DUPLICATE of bug 725588
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 08:44 UTC by Sachin Ghai
Modified: 2011-09-07 19:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 19:22:23 UTC


Attachments (Terms of Use)
After editing, repo url throwing an error on UI (40.11 KB, image/png)
2011-09-05 08:47 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2011-09-05 08:44:20 UTC
Description of problem:
when you edit a repo's URL, it throws following error on UI:

undefined method `values' for nil:NilClass

Version-Release number of selected component (if applicable):
katello-0.1.75-1.git.41.2e9f377.fc15.noarch


How reproducible:
always

Steps to Reproduce:
1. Create a custom product provider
2. Add a product
3. Under that product, add a repo with URL.
4. Now edit the newly created repo's URL 
  
Actual results:
undefined method `values' for nil:NilClass

Expected results:
URL should be updated without any error.

Additional info:

Comment 1 Sachin Ghai 2011-09-05 08:47:33 UTC
Created attachment 521447 [details]
After editing, repo url throwing an error on UI

Comment 2 Mike McCune 2011-09-07 19:22:23 UTC

*** This bug has been marked as a duplicate of bug 725588 ***


Note You need to log in before you can comment on or make changes to this bug.