Bug 735759 - [webadmin] Cannot open the 'add' dialog after saving a new DC.
Summary: [webadmin] Cannot open the 'add' dialog after saving a new DC.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: m2
: 3.1
Assignee: Einav Cohen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 10:05 UTC by Asaf Shakarchi
Modified: 2012-08-09 08:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-09 08:02:22 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Asaf Shakarchi 2011-09-05 10:05:29 UTC
Cannot open the 'add' dialog after saving a new DC.

Comment 1 Vojtech Szocs 2011-09-05 10:34:51 UTC
Happens because getWindow() != null within DataCenterListModel.New(), after trying to open "New DC" dialog

Comment 2 Vojtech Szocs 2011-09-05 10:41:23 UTC
Root cause of this issue:

after creating new DC, the "window" property is changed to DataCenterGuideModel (another dialog as part of new DC dialog)

popup bound to DataCenterGuideModel isn't implemented yet (DataCenterModule.getDataCenterListProvider.onWindowModelChange) and therefore isn't handled properly

because of this, the "window" property retains the reference to DataCenterGuideModel, this breaks subsequent attempts to show dialogs

Comment 3 Vojtech Szocs 2011-09-05 10:44:25 UTC
To fix this issue, popup PresenterWidget/View bound to DataCenterGuideModel needs to be implemented, and handled within DataCenterModule.getDataCenterListProvider.onWindowModelChange method

Comment 4 Vojtech Szocs 2011-09-07 09:18:27 UTC
Alternatively, we can call getModel().setWindow(null) for unsupported dialog models (e.g. DataCenterGuideModel) within the onWindowModelChange() method.

This will nullify the "window" property and ensure that methods showing dialogs (e.g. DataCenterListModel's New or Edit) will pass.

Comment 5 Vojtech Szocs 2011-09-22 13:09:32 UTC
This issue has been addressed by patch "webadmin: Handle missing dialogs gracefully" (pending review/ack).

Comment 6 Danny Rankevich 2011-10-06 11:35:40 UTC
fixed in commit	d5518948763d59b9d945ecb34bab0ba0067e98f2

Comment 8 Itamar Heim 2012-08-09 08:02:22 UTC
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Comment 9 Itamar Heim 2012-08-09 08:03:36 UTC
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/


Note You need to log in before you can comment on or make changes to this bug.