Bug 735766 - [virt-manager]should hide storage format which qemu disable support
Summary: [virt-manager]should hide storage format which qemu disable support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 10:21 UTC by zhe peng
Modified: 2012-06-20 12:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed
Clone Of:
Environment:
Last Closed: 2012-06-20 12:35:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0785 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2012-06-19 20:34:46 UTC

Description zhe peng 2011-09-05 10:21:33 UTC
Description of problem:
create volume should hide un-support format 

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
python-virtinst-0.600.0-3.el6.noarch
libvirt-0.9.4-7.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.click "Edit"->"Connection Details"
2.switch to "Storage"
3.add new volume in a pool
4.select Format of file
  
Actual results:
list have raw,cow,qcow,qcow2,vmdk,vpc

Expected results:
only have raw, qcow2

Additional info:
refer bug https://bugzilla.redhat.com/show_bug.cgi?id=710337
use vpc of file format,the volume will created, but if guest use this volume,will cause error:
qemu: 'vpc' invalid format
so, should hide cow, qcow,vmdk,vpc in format list.

Comment 3 Cole Robinson 2011-09-27 15:48:22 UTC
Not a huge priority so deferring to 6.3

Comment 5 Cole Robinson 2012-01-25 22:01:54 UTC
Moving to POST since it's upstream

Comment 6 Cole Robinson 2012-02-01 20:03:58 UTC
Fixed in virt-manager-0.9.0-8.el6

Comment 8 zhe peng 2012-02-10 07:34:26 UTC
verify with:
virt-manager-0.9.0-9.el6
python-virtinst-0.600.0-7.el6

Steps to Reproduce:
1.click "Edit"->"Connection Details"
2.switch to "Storage"
3.add new volume in a pool
4.select Format of file
now the format are:
raw qcow2 qed
for format qed, refer Bug 739487

verification passed,move to verified.

Comment 9 Cole Robinson 2012-06-12 15:25:15 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed

Comment 11 errata-xmlrpc 2012-06-20 12:35:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0785.html


Note You need to log in before you can comment on or make changes to this bug.