Bug 73579 - kickstart: network --bootproto static is ignored
kickstart: network --bootproto static is ignored
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-06 05:01 EDT by ronny.lampert
Modified: 2007-03-26 23:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-06 05:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ronny.lampert 2002-09-06 05:01:31 EDT
Description of Problem:
In the attached ks.cfg you find network --bootproto static; this is simply
ignored and a dhcp-request is sent, causing (for misterious reasons) the install
to terminate with signal 11,too.

Version-Release number of selected component (if applicable):


How Reproducible:
Always.

Steps to Reproduce:
1.make bootdisk
2.copy ks.cfg below to disk
3. at prompt type: ks ks=floppy

Actual Results:
installer is sending a dhcp request although ks.cfg contains instruction to use
static ip configuration.

Expected Results:
Using given ip/gateway-information and configuring the interface static.

Additional Information:

The .isos have been successfully checked with md5.	

Here's the ks.cfg attached (long lines may be wrapped thru mozilla; in the file
there is no such wrapping):

network --bootproto static --ip 164.48.191.48 --gateway 164.48.191.20
--nameserver 164.48.126.10 --netmask 255.255.255.0
lang en_US
langsupport --default en_US en_US 
keyboard de-latin1-nodeadkeys
# if mouse not given, probe for it
mouse genericps/2
deviceprobe
timezone --utc Europe/Berlin
rootpw --iscrypted <randomstuff>
reboot
text
bootloader --useLilo --nolinear --location=mbr 
install
#nfs --server eedn26ls --dir /export/apps3/linux/RH7.3
url --url ftp://<user>:<passwd>@eedn760l/opt/RH73
clearpart --linux 
part /boot --fstype ext2 --size 32
part / --fstype ext2 --size 500 
part  swap --size 256 
part /usr --fstype ext2 --size 1500 --grow --maxsize 2000 
part /opt --fstype ext2 --size 16 --grow 
auth  --useshadow  --enablenis --nisdomain eedn.ericsson.se
firewall --disabled 
#XWindows configuration information
#Probe for video card
#Probe for monitor
xconfig  --depth 16 --resolution 1024x768 --defaultdesktop=GNOME --startxonboot

%packages --ignoredeps
mailcap
filesystem
bzip2-libs
db2
glib2
ksymoops
mktemp
pcre
perl-DB_File
newt
bash
libstdc++
ncurses
ed
gawk
openssl
sed
sysklogd
dev
tmpwatch
vim-common
cracklib-dicts
cyrus-sasl-md5
modutils
mkbootdisk
zlib
vixie-cron
esound
ghostscript-fonts
htmlview
libpng
libxml
m4
netpbm
Omni
perl-DateManip
perl-libnet
perl-Storable
perl-XML-Grove
perl-XML-Twig
portmap
pkgconfig
libungif
locale_config
libglade2
pygtk-libglade
pygtk2
Xaw3d
ttfonts
mkxauth
pspell
desktop-backgrounds
fam
gnome-audio-extra
gqview
libgal19
gnome-print
librep
bonobo-conf
control-center
gtkhtml
pygnome-gtkhtml
rep-gtk
gnome-applets
sgml-common
gnumeric
scrollkeeper
ftp
nmap
openldap-clients
yp-tools
cpp
perl-SGMLSpm
bc
rsync
vim-enhanced
autoconf
binutils
byacc
ddd
flex
glib-devel
indent
#libcap-devel
libstdc++-devel
libtool
ltrace
ncurses-devel
openldap-devel
pam-devel
pygtk-devel
python2-devel
rpm-devel
gtk+-devel
lesstif-devel
zlib-devel
gdk-pixbuf-devel
LPRng
ghostscript
mozilla-nspr
nss_ldap
openssh-clients
man-pages
setup
basesystem
bdflush
chkconfig
db3
e2fsprogs
file
glib
hdparm
iputils
losetup
mingetty
perl
perl-CPAN
perl-NDBM_File
pwdb
setserial
slang
netconfig
setuptool
libtermcap
bzip2
iproute
groff
MAKEDEV
info
diffutils
fileutils
findutils
grep
dhcpcd
less
man
procmail
readline
rootfiles
console-tools
tar
textutils
mount
time
utempter
vim-minimal
words
pam
cyrus-sasl
cyrus-sasl-plain
openldap
passwd
krb5-libs
kudzu
lilo
rpm
initscripts
ipchains
pciutils
timeconfig
anacron
audiofile
expat
freetype
gmp
groff-perl
libcap
libmng
libtiff
libxml2
make
mpage
netpbm-progs
ORBit
perl-HTML-Parser
perl-libxml-enno
perl-Parse-Yapp
perl-URI
perl-XML-Encoding
perl-XML-Parser
perl-XML-Dumper
foomatic
pnm2ppa
psutils
python
PyXML
switchdesk
gdk-pixbuf
imlib
libglade
openmotif
gtk2
pygtk
pygnome-libglade
ksconfig
pygtk2-libglade
qt
tk
tix
chkfontpath
VFlib2
Xconfigurator
xinitrc
xloadimage
libtool-libs
aumix
dia
extace
gal
gftp
gnome-mime-data
gnupg
gtk-engines
imlib-cfgeditor
libghttp
libgnomeprint15
libgtop
libole2
librsvg
mc
oaf
GConf
bug-buddy
eel
gnome-vfs-extras
Guppi
intltool
python-popt
python-xmlrpc
rep-gtk-gnome
rpm-python
gnome-core
pygnome-applet
switchdesk-gnome
guile
xml-common
#openjade
xscreensaver
autofs
cipe
finger
gq
libpcap
micq
nfs-utils
nmap-frontend
radvd
redhat-config-network
rsh
glibc
bind-utils
gdb
glibc-kernheaders
mozilla
mozilla-dom-inspector
mozilla-nss-devel
nscd
openssh
openssh-askpass-gnome
openssh-server
psmisc
xchat
stunnel
tcp_wrappers
traceroute
wget
ypbind
lockdev
gd
mm
#docbook-style-dsssl
#docbook-utils
docbook-dtds
#tamago
lsof
pax
procinfo
screen
sudo
tree
usbview
xdelta
automake
bison
bonobo-devel
bzip2-devel
ctags
curl-devel
cyrus-sasl-devel
db2-devel
db3-utils
dev86
doxygen
eel-devel
fam-devel
freetype-devel
gd-devel
gdbm-devel
glade
gcc
gnome-core-devel
gnumeric-devel
guile-devel
lesstif
libghttp-devel
libjpeg-devel
libole2-devel
librsvg-devel
gcc-c++
libtiff-devel
libungif-devel
libxml-devel
lockdev-devel
memprof
modutils-devel
ncompress
netpbm-devel
oaf-devel
openmotif-devel
ORBit-devel
parted-devel
pciutils-devel
pcre-devel
audiofile-devel
glib2-devel
pmake
pygnome-devel
python-devel
rcs
rpm-build
newt-devel
strace
texinfo
Xaw3d-devel
GConf-devel
gnome-vfs-devel
pango-devel
libglade2-devel
imlib-devel
control-center-devel
gnome-print-devel
libglade-devel
libpng-devel
rsh-server
openssl095a
kernel
mozilla-mail
mozilla-nss
hwdata
redhat-logos
cracklib
dosfstools
gdbm
mailx
net-tools
perl-CGI
popt
shadow-utils
termcap
crontabs
logrotate
cpio
at
gzip
procps
redhat-release
kbdconfig
tcsh
mouseconfig
which
authconfig
gpm
sh-utils
mkinitrd
SysVinit
util-linux
iptables
quota
atk
fortune-mod
gnome-audio
libjpeg
libxslt
efax
nkf
perl-HTML-Tagset
perl-MIME-Base64
perl-libwww-perl
perl-libxml-perl
Omni-foomatic
a2ps
python2
tcl
gtk+
gnome-libs
pango
pygnome
hwbrowser
tkinter
urw-fonts
xinetd
xsri
ee
gdk-pixbuf-gnome
gnome-user-docs
gnorpm
gtop
libunicode
bonobo
gnome-vfs
gedit
patch
python-clap
rep-gtk-libglade
sawfish
gnome-utils
umb-scheme
gdm
curl
#compat-libstdc++
rdate
telnet
whois
dialog
xemacs
xemacs-el
ical
#pinfo
stat
#units
xpdf
#automake15
bonobo-conf-devel
db3-devel
diffstat
gal-devel
gettext
gmp-devel
gpm-devel
libgtop-devel
libtermcap-devel
libunicode-devel
libxml2-devel
openssl-devel
patchutils
esound-devel
pygtk2-devel
readline-devel
slang-devel
gtk2-devel
gnome-libs-devel
wu-ftpd
glibc-common
dateconfig
glibc-devel
mozilla-psm
openssh-askpass
perl-Digest-MD5
XFree86-libs
XFree86-tools
XFree86-xdm
XFree86-font-utils
XFree86-100dpi-fonts
XFree86-75dpi-fonts
XFree86
XFree86-ISO8859-15-75dpi-fonts
XFree86-twm
XFree86-devel
XFree86-xfs
XFree86-base-fonts
XFree86-ISO8859-15-100dpi-fonts
hpijs
Canna-libs
cups-libs
atk-devel
alchemist
openjade
postgresql-libs
Glide3

%post
SERVERDIR=eedn26ls:/export/apps3/linux
CONFDIR=eedn_config
LOCATION=lab
VERSION=2.4.19
MP=/tmp/eedn

# SERVICE CONFIGURATION
echo -e "Configuring services\r"
chkconfig --del sendmail
chkconfig --del apmd
chkconfig --del kudzu
# this is for xinetd
chkconfig rsh on
chkconfig rlogin on
chkconfig ftp on
#
rpm -e apmd pidentd

echo -e "Mounting server-dir $SERVERDIR"
mkdir $MP
mount -t nfs $SERVERDIR /tmp/eedn

# MISC
echo -e "Doing misc. stuff"
echo ". /etc/bashrc" > /root/.bashrc
( cd /usr/local/bin && ln -s `which perl` perl )
( cd /usr/local/bin && ln -s `which rdist` . )
( cd /usr/local/bin && ln -s `which rdistd` . )
#
echo -e "Unpacking kernel source $VERSION\r"
rm -rf /usr/src/linux
rm -rf /usr/src/linux-$VERSION 
bzip2 -dc $MP/$CONFDIR/linux-$VERSION.tar.bz2 | tar xf - -C /usr/src
cd /usr/src

# KERNEL + CONFIG
test -d linux && mv linux linux-$VERSION
(test -d linux-$VERSION || test -l linux-$VERSION) && ln -s linux-$VERSION linux
&& ln -s linux linux-24 && \
cp $MP/$CONFDIR/$LOCATION/kernel-$VERSION.conf linux/.config && cd linux && make
oldconfig \
|| echo -e "Problem with Linux-Sources!\r"
#
echo -e "Installing Kernel\r"
tar xzPvf $MP/$CONFDIR/$LOCATION/kernel-$VERSION.tar.gz -C /
Comment 1 ronny.lampert 2002-09-09 08:22:02 EDT
The static configuration seems to be used during install and installed system;
but the "Sending DHCP-request"-window is still shown and there is also one
DHCP-request sent.

The signal 11 seems to be generated by the false langsupport-entry (NOTE: The
above ks.cfg was generated using kickstart-configurator!).
I took the anaconda-ks.cfg from a manually installed system and these entries work:

lang en_US
langsupport --default en_US.iso885915 en_US.iso885915


Note You need to log in before you can comment on or make changes to this bug.