Bug 73581 - SquirrelMail/PHP interaction
SquirrelMail/PHP interaction
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: squirrelmail (Show other bugs)
8.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-06 06:59 EDT by Gary Benson
Modified: 2007-03-26 23:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:53:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Benson 2002-09-06 06:59:49 EDT
On Fri, Aug 23, 2002 at 08:00:46PM +0300, sonmez wrote on limbo-list:

> When I changed squirrelmail_default_language to tr_TR in
> /etc/squirrelmail/config.php I got this error,
> > Fatal error: Call to undefined function: quote}map() in
> /usr/share/squirrelmail/functions/imap_general.php on
> line 217
> > in en_US there is no problem.
> any idea?

As well as the usual bindtextdomain() and textdomain() stuff, SquirrelMail sets
a bunch of environment variables in functions/i18n.php:

  putenv( "LC_ALL=$sm_notAlias" );
  putenv( "LANG=$sm_notAlias" );
  putenv( "LANGUAGE=$sm_notAlias" );

I think that one of these is affecting the character set that PHP uses to parse
the files.  I don't know whether this should be considered a bug in PHP or a bug
in SquirrelMail.

Version-Release number of selected component (if applicable):
squirrelmail-1.2.7-4 and php-4.2.2-8.0.5

How Reproducible:
Always
Comment 1 Warren Togami 2004-10-20 21:51:18 EDT
Is this still an issue in FC3/RHEL4?
Or even RHEL3?
Comment 2 Warren Togami 2004-11-27 17:53:30 EST
closing due to lack of activity.

Note You need to log in before you can comment on or make changes to this bug.