Bug 73593 - Printing to HP LaserJet IIISi causes printer error
Summary: Printing to HP LaserJet IIISi causes printer error
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-06 14:22 UTC by Wade Minter
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 16:04:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/cups/printers.conf ("office" is the one) (534 bytes, text/plain)
2002-10-07 13:39 UTC, Wade Minter
no flags Details
office.ppd (18.72 KB, text/plain)
2002-10-07 13:59 UTC, Wade Minter
no flags Details
cupsomatic.log (1.78 KB, text/plain)
2002-10-07 14:24 UTC, Wade Minter
no flags Details
prnjob (15.57 KB, text/plain)
2002-10-07 14:25 UTC, Wade Minter
no flags Details
cupsomatic.log after commenting out PJL line. (1.78 KB, text/plain)
2002-10-07 14:42 UTC, Wade Minter
no flags Details

Description Wade Minter 2002-09-06 14:22:19 UTC
Description of Problem:

This may well be a hardware problem, but I'm trying to use CUPS to print
to a network-attached HP Laserjet IIISi in my office.  I'm using the "HP
Laserjet 3, Foomatic + Gimp-Print(en)" driver and printing to an lpd queue
on the remote IP.

Whenever I try to print anything, the printer immediately throws up a
blinking number 30 and "PS Error 24" error.  Windows clients can print to
the printer just fine.

Comment 1 Tim Waugh 2002-10-07 13:15:47 UTC
Does this still happen in Red Hat Linux 8.0?  If so, please attach your 
/etc/cups/printers.conf.  Also, have you tried printing the CUPS test page?

Comment 2 Wade Minter 2002-10-07 13:36:50 UTC
Just tried it under 8.0, and it still failed, although this time it was a "30 PS
ERROR 18" error.

I'll attach printers.conf

Comment 3 Wade Minter 2002-10-07 13:39:43 UTC
Created attachment 79187 [details]
/etc/cups/printers.conf ("office" is the one)

Comment 4 Tim Waugh 2002-10-07 13:46:11 UTC
Please attach /etc/cups/ppd/office.ppd.

Comment 5 Wade Minter 2002-10-07 13:59:58 UTC
Created attachment 79188 [details]
office.ppd

Comment 6 Tim Waugh 2002-10-07 14:06:49 UTC
This is in fact "HP LaserJet 3, Foomatic + ljet3", but that's the recommended 
driver so it should be alright. 
 
Have you tried printing the CUPS test page?

Comment 7 Wade Minter 2002-10-07 14:11:44 UTC
Yes - printing the CUPS test page is what causes the PS ERROR on the printer itself.

I'd think it was a weird printer hardware problem, but the Windows clients in
the office can print to it fine.

Comment 8 Tim Waugh 2002-10-07 14:13:41 UTC
What does 'lpoptions -p office' say?

Comment 9 Wade Minter 2002-10-07 14:17:00 UTC
[root@localhost root]# lpoptions -p office
job-sheets=none,none
[root@localhost root]#


Comment 10 Tim Waugh 2002-10-07 14:21:01 UTC
In /usr/lib/cups/filter/cupsomatic, on line 28, there is a line that reads: 
 
my $debug = 0; 
 
Please change it to: 
 
my $debug = 1; 
 
and print the CUPS test page again.  You will have two new files in /tmp: 
cupsomatic.log and prnjob.  Please attach them.  Thanks.

Comment 11 Wade Minter 2002-10-07 14:24:33 UTC
Created attachment 79189 [details]
cupsomatic.log

Comment 12 Wade Minter 2002-10-07 14:25:06 UTC
Created attachment 79190 [details]
prnjob

Comment 13 Tim Waugh 2002-10-07 14:30:11 UTC
In /usr/share/foomatic/db/source/printer/78144.xml, at line 21, there is a  
line that reads:  
  
    <pjl/>  
  
Please change that to:  
  
    <!-- pjl/ -->  
  
Try printing the CUPS test page again, and see the /tmp/cupsomatic.log still  
talks about PJL. 
 
(I'm trying to see if it's the PJL job wrapper that's causing the problem.)

Comment 14 Wade Minter 2002-10-07 14:42:24 UTC
I commented that line out, restarted cupsd, and printed a new test page.  The
log still, though, appears to reference PJL.

Comment 15 Wade Minter 2002-10-07 14:42:54 UTC
Created attachment 79192 [details]
cupsomatic.log after commenting out PJL line.

Comment 16 Tim Waugh 2002-10-07 15:11:02 UTC
Oh, because the PPD file is already generated, I suppose.  Please remove this 
line from /etc/cups/ppd/office.ppd: 
 
*% COMDATA #  'pjl' => '', 
 
and try again.  Thanks.

Comment 17 Wade Minter 2002-10-07 15:19:26 UTC
No mention of PJL in the cupsomatic.log, but I still see the exact same error on
the printer.

Comment 18 Tim Waugh 2002-10-11 14:42:18 UTC
http://www.nefec.org/UPM/printers/mhp3si.htm offers more clues. 
 
Can you print /usr/share/cups/data/testprint.ps from a Windows machine, or 
does that give the same error?

Comment 19 Tim Waugh 2003-04-09 16:04:26 UTC
Suggest printer BIOS upgrade, if one is available.


Note You need to log in before you can comment on or make changes to this bug.