Bug 735932 - vds_bootstrap: do not download and do not use redhat-lsb
Summary: vds_bootstrap: do not download and do not use redhat-lsb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: Kiril Nesenko
URL:
Whiteboard:
: 736688 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 07:48 UTC by Dan Kenigsberg
Modified: 2014-07-11 00:08 UTC (History)
8 users (show)

Fixed In Version: vdsm-4.9-99.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:26:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Dan Kenigsberg 2011-09-06 07:48:03 UTC
redhat-lsb has a very heavy dependency that slows down installation, while all we need from it is finding OS version.

Version-Release number of selected component (if applicable):
vdsm-bootstrap-4.9-96

How reproducible:
always

Steps to Reproduce:
1. add host from rhevm to a rhel box with no redhat-lsb.rpm
  
Actual results:
redhat-lsb.rpm is installed on rhel box; install time may exceed 8 minutes.

Expected results:
installation works well without redhat-lsb

Comment 1 Itamar Heim 2011-09-06 08:07:20 UTC
need to check what do we rely on, and which rpm may be needed for it (say, /etc/redhat-release)

Comment 2 Dan Kenigsberg 2011-09-06 08:27:17 UTC
Note that the removal of lsb dependency was formerly requested (and denied) in bug 689661.

(and in reply to comment #1)
Itamar, I do not understand your English.

Comment 3 Dan Kenigsberg 2011-09-06 08:41:09 UTC
Posted upstream: http://gerrit.usersys.redhat.com/898

Comment 4 Dan Kenigsberg 2011-09-07 09:54:27 UTC
(In reply to comment #1)
> need to check what do we rely on, and which rpm may be needed for it (say,
> /etc/redhat-release)

/etc/redhat-release is very very basic, and supplied by several packages redhat-release-*. it is already implicitly required by vdsm.

Comment 6 Dan Kenigsberg 2011-09-08 12:40:54 UTC
*** Bug 736688 has been marked as a duplicate of this bug. ***

Comment 7 yeylon@redhat.com 2011-09-22 10:46:12 UTC
ic142
vdsm-bootstrap-4.9-104.el6.x86_64

Comment 8 errata-xmlrpc 2011-12-06 07:26:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.