Bug 735988 - VDR cannot tune into DVB-T2 channels
Summary: VDR cannot tune into DVB-T2 channels
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vdr
Version: 15
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 11:27 UTC by Chris Rankin
Modified: 2011-11-07 16:02 UTC (History)
2 users (show)

Fixed In Version: 1.7.21-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-07 16:02:40 UTC


Attachments (Terms of Use)

Description Chris Rankin 2011-09-06 11:27:04 UTC
Description of problem:
VDR cannot tune my PCTV 290e DVB-T2 adapter into any HD channel.

Version-Release number of selected component (if applicable):
vdr-1.6.0-40.fc15.i686

How reproducible:
All the time.

Steps to Reproduce:
1. Plug DVB-T2 adapter into PC.
2. Generate new channels.conf file for w_scan, confirming that HD channels are present.
3. Start VDR, and select one of the HD channels.
  
Actual results:
VDR front end displays blank window with message "No signal", and entries in channels.conf file are not updated.

Expected results:
VDR displays HD channel.

Additional info:
The lines in my channels.conf file say:

BBC HD;BBC:554000:I999B8C999D999M999T999G999Y999:T:27500:101:0:0:0:17472:0:0:0
BBC One HD;BBC:554000:I999B8C999D999M999T999G999Y999:T:27500:6601:0:0:0:17540:0:0:0
ITV1 HD;ITV:554000:I999B8C999D999M999T999G999Y999:T:27500:201:0:0:0:17604:0:0:0
Channel 4 HD;CHANNEL FOUR:554000:I999B8C999D999M999T999G999Y999:T:27500:301:0:0:0:17664:0:0:0

I am expecting VDR to replace the "999" values with the tuned results.

This is almost certainly already fixed in VDR 1.7.x.

Comment 1 Ville Skyttä 2011-11-07 16:02:40 UTC
VDR 1.7.21 is now in Rawhide.  I don't have a way to test DVB-T2 myself nor do I plan to push the 1.7.x update to F-16 and earlier due to its development status and potential backward compatibility issues, but if you're adventurous, this is what I'm currently running with my F-15 based VDR setup:

1) vdr and vdr-text2skin Rawhide SRPMS locally rebuilt for F-15 in mock.  The Rawhide vdr binary package would require a glibc upgrade, and the text2skin binary package from Rawhide doesn't work on F-15 due to some GraphicsMagick differences.

2) All other vdr* packages I use are from Rawhide as is: installed the fedora-release-rawhide package and added these lines to /etc/yum.repos.d/fedora-rawhide.repo's [rawhide] section:

    includepkgs=vdr*
    exclude=vdr-1* vdr-text2skin


Note You need to log in before you can comment on or make changes to this bug.