Bug 736001 - getVdsCaps fails when there is more that one "redhat-release-server" package
Summary: getVdsCaps fails when there is more that one "redhat-release-server" package
Keywords:
Status: CLOSED DUPLICATE of bug 744549
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 11:45 UTC by Rami Vaknin
Modified: 2016-04-18 06:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-05 20:04:56 UTC
oVirt Team: ---


Attachments (Terms of Use)
vdsm logs (794.09 KB, application/x-gzip)
2011-09-06 11:45 UTC, Rami Vaknin
no flags Details

Description Rami Vaknin 2011-09-06 11:45:51 UTC
Created attachment 521638 [details]
vdsm logs

Environment:
RHEVM 3.0 ic139 with RHEL6.2 host, vdsm-4.9-96.el6.x86_64

"vdsClient -s 0 getVdsCaps" fails with "unexpected exception" when there are two "redhat-release-server" packages installed, therefore the host moves to "Non-responsive" after the installation's reboot.

rpm -qa | grep redhat-release
redhat-release-server-6Server-6.2.0.2.el6.x86_64
redhat-release-server-6Server-6.1.0.2.el6.x86_64


From vdsm.log:

Thread-54::DEBUG::2011-09-05 22:37:35,649::clientIF::54::vds::(wrapper) [10.35.70.18]::call getVdsCapabilities with () {}
Thread-54::ERROR::2011-09-05 22:37:35,678::caps::132::root::(osversion) failed to find version/release
Traceback (most recent call last):
  File "/usr/share/vdsm/caps.py", line 128, in osversion
    version, release = out.split()
ValueError: too many values to unpack
Thread-54::ERROR::2011-09-05 22:37:35,678::clientIF::68::vds::(wrapper) Traceback (most recent call last):
  File "/usr/share/vdsm/clientIF.py", line 58, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/clientIF.py", line 711, in getVdsCapabilities
    c = caps.get()
  File "/usr/share/vdsm/caps.py", line 168, in get
    caps['operatingSystem'] = osversion()
  File "/usr/share/vdsm/caps.py", line 134, in osversion
    __osversion = dict(release=release, version=version, name=osname)
UnboundLocalError: local variable 'release' referenced before assignment

Comment 2 Dan Kenigsberg 2012-03-05 20:04:56 UTC

*** This bug has been marked as a duplicate of bug 744549 ***


Note You need to log in before you can comment on or make changes to this bug.