This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 7361 - Dazed and Confused
Dazed and Confused
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-26 20:41 EST by tim_stewart
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 17:27:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tim_stewart 1999-11-26 20:41:58 EST
I just installed Red Hat Linux 6.1 on my Compaq Presario 1230 Laptop.  The
first time I exited XWindows (GNOME), An error message kept printing to
the screen.  It began "Dazed and Confused" and told me that an NMI had
occurred.  It asked me if I had a "strange power saving mode"?  I looked
at my /proc/apm file; it says "1.9 1.2 0x03 0x01 0x03 0x09 100% -1 ?".
When I run apm I get "AC on-line, battery charging: 100%".  The other time
I got these error messages (the same one over and over) was right after I
ran sndconfig.  The error message repeatedly prints to all of the virtual
consoles.  I am able to "shutdown -r now" so the problem is more of a
major annoyance than a debilitating bug.  My computer does have a PCMCIA
slot and I have a LinkSys network card in it.  I did a search for the
error message and it is being printed out from traps.c (if that's even
helpful to you).  Thanks a lot for your help.

Dazed and Confused,
Timothy Stewart
Comment 1 tim_stewart 1999-11-27 10:27:59 EST
My laptop has several buttons on it that increase or decrease the speaker
volume, or start Internet Explorer.  I just noticed that whenever I press one
of these buttons, I start getting the "NMI" error message.  I don't remember if
I had pressed one of the buttons prior to each error message but I won't be
adjusting the volume any more.  If I go a few days without seeing the error
message again, I'll let you know.  By the way, killing apmd had no effect on
whether or not I see the error messages.
Comment 2 Bernhard Rosenkraenzer 1999-11-28 08:44:59 EST
Probably a broken BIOS... Maybe it can be worked around in the kernel.
Definitely not an apmd problem.
Comment 3 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 4 Alan Cox 2000-08-08 13:29:45 EDT
This is BIOSes using NMI for internal magic. The sound card NMI is typically
emulation mode stuff caused by the wrong driver being used

Nothing the kernel can do here

Note You need to log in before you can comment on or make changes to this bug.