Bug 736103 - [vdsm][resourceFactories] when prepareVolume gets timeout error on acquire exclusive resource, it doesn't fail.
Summary: [vdsm][resourceFactories] when prepareVolume gets timeout error on acquire ex...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Saggi Mizrahi
QA Contact: David Naori
URL:
Whiteboard: scalability, storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 17:27 UTC by David Naori
Modified: 2011-12-06 07:26 UTC (History)
8 users (show)

Fixed In Version: vdsm-4.9-101
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:26:29 UTC


Attachments (Terms of Use)
vdsm.log (387.45 KB, application/x-xz)
2011-09-06 17:27 UTC, David Naori
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description David Naori 2011-09-06 17:27:53 UTC
Created attachment 521717 [details]
vdsm.log

Description of problem:
when prepareVolume gets timeout error on acquire exclusive resource, it doesn't fail.  instead, it successfully acquire the "exclusive" lock while its actually shared.


Thread-101::DEBUG::2011-09-06 20:07:07,201::resourceManager::490::ResourceManager::(registerResource) Resource 'ccbe9419-e910-4a9a-a742-8693aa1f503c_volumeNS.66ed30f7-539a-4fd2-8c1d-88a781429dc6' is currently locked, Entering queue (5 in
 queue)

** 5 in queue ** 

#### after 2 minutes timeout #####
Thread-101::DEBUG::2011-09-06 20:09:07,202::resourceManager::165::ResourceManager.Request::(cancel) ResName=`ccbe9419-e910-4a9a-a742-8693aa1f503c_volumeNS.66ed30f7-539a-4fd2-8c1d-88a781429dc6`ReqID=`a0043f7b-4508-435e-b2bc-c7913fe26c79`::Canceled request
Thread-101::DEBUG::2011-09-06 20:09:07,203::resourceFactories::158::Storage.ResourcesFactories::(__getResourceCandidatesList) Cannot acquire volume resource (Request timed out. Could not acquire resource 'ccbe9419-e910-4a9a-a742-8693aa1f503c_volumeNS.66ed30f7-539a-4fd2-8c1d-88a781429dc6')
Thread-101::DEBUG::2011-09-06 20:09:07,204::resourceManager::508::ResourceManager::(registerResource) Resource 'ccbe9419-e910-4a9a-a742-8693aa1f503c_imageNS.d5a88bda-aa4a-47a2-a9a3-fbfbc7f3091b' is free. Now locking as 'exclusive' (1 active user)
Thread-101::DEBUG::2011-09-06 20:09:07,205::resourceManager::191::ResourceManager.Request::(grant) ResName=`ccbe9419-e910-4a9a-a742-8693aa1f503c_imageNS.d5a88bda-aa4a-47a2-a9a3-fbfbc7f3091b`ReqID=`0d6c3b22-164d-4a01-869f-74322f5310ac`::Granted request



        except (rm.RequestTimedOutError, se.ResourceAcqusitionFailed), e:
            log.debug("Cannot acquire volume resource (%s)", str(e))
        except Exception, e:
            log.debug("Cannot acquire volume resource", exc_info=True)

        if e:
            # Release already acquired template/volumes locks
            for volRes in volResourcesList:
                volRes.release()

        return volResourcesLis



Version-Release number of selected component (if applicable):
vdsm-4.9-96.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.run 5 vms with 24 disks
  
Actual results:


Expected results:


Additional info:

Comment 2 Saggi Mizrahi 2011-09-08 09:25:58 UTC
http://gerrit.usersys.redhat.com/#change,915

Comment 4 David Naori 2011-09-25 14:23:22 UTC
Verified on vdsm-4.9-103.el6.x86_64

Comment 5 errata-xmlrpc 2011-12-06 07:26:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.