Bug 736159 - xdg-screensaver thinks I'm in gnome when xscreensaver is running
Summary: xdg-screensaver thinks I'm in gnome when xscreensaver is running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-utils
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 20:39 UTC by Jesper Friis
Modified: 2011-12-27 22:58 UTC (History)
2 users (show)

Fixed In Version: xdg-utils-1.1.0-0.10.20111207.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-22 22:36:57 UTC


Attachments (Terms of Use)

Description Jesper Friis 2011-09-06 20:39:48 UTC
Description of problem:
Cannot lock screen (with running xscreensaver) under LXDE when gnome-screensaver is installed.

Version-Release number of selected component (if applicable): fc15


How reproducible:
Always

Steps to Reproduce:
1. Start LXDE with xscreensaver running
2. Install gnome-screensaver
3. Press the lock screen button
  
Actual results:
Nothing happens

Expected results:
Screen should lock

Additional info:
The problem seems to be related to the following lines (starting at line 1041) in xdg-screensaver:

# Consider "xscreensaver" a separate DE
xscreensaver-command -version 2> /dev/null | grep XScreenSaver > /dev/null && DE="xscreensaver"
# Consider "gnome-screensaver" a separate DE
gnome-screensaver-command -q > /dev/null 2>&1 && DE="gnome_screensaver"

No check is done whether respective screensaver is actually running. Replacing
the above lines with the following seems actually solves the problem:

# Consider "xscreensaver" a separate DE
pgrep -s0 xscreensaver >/dev/null 2>&1 && DE="xscreensaver"
# Consider "gnome-screensaver" a separate DE
pgrep -s0 gnome-screensaver >/dev/null 2>&1 && DE="gnome_screensaver"

This bug might very well be related to bug 702540.

Comment 1 Fedora Update System 2011-12-07 18:56:55 UTC
xdg-utils-1.1.0-0.10.20111207.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xdg-utils-1.1.0-0.10.20111207.fc16

Comment 2 Fedora Update System 2011-12-07 19:18:35 UTC
xdg-utils-1.1.0-0.10.20111207.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xdg-utils-1.1.0-0.10.20111207.fc15

Comment 3 Fedora Update System 2011-12-10 19:38:01 UTC
Package xdg-utils-1.1.0-0.10.20111207.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xdg-utils-1.1.0-0.10.20111207.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16850/xdg-utils-1.1.0-0.10.20111207.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-12-22 22:36:57 UTC
xdg-utils-1.1.0-0.10.20111207.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-12-27 22:58:50 UTC
xdg-utils-1.1.0-0.10.20111207.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.