Bug 736198 - cman update hangs yum transaction
Summary: cman update hangs yum transaction
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cluster
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 736200 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 00:31 UTC by Jerry Amundson
Modified: 2011-09-07 06:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 06:39:19 UTC


Attachments (Terms of Use)

Description Jerry Amundson 2011-09-07 00:31:02 UTC
Description of problem:
cman update hangs yum transaction

Version-Release number of selected component (if applicable):
cman-3.1.6-1.fc15.i686

How reproducible:
once

Steps to Reproduce:
1.yum update 
2.
3.
  
Actual results:
update hangs

Expected results:
complete update

Additional info:
Running processes:
root      9047  1961  7 17:38 pts/0    00:04:58 /usr/bin/python /usr/bin/yum -y update
root     10599  9047  0 17:59 pts/0    00:00:00 /bin/sh /var/tmp/rpm-tmp.MSI6Hy 2
root     10605 10599  0 17:59 pts/0    00:00:00 /bin/bash /usr/sbin/ccs_update_schema
root     10607 10605  0 17:59 pts/0    00:00:00 /bin/bash /usr/sbin/ccs_update_schema
root     10705 10607  0 17:59 pts/0    00:00:00 /usr/bin/perl -w /usr/share/cluster/checkquorum meta-data
root     10706 10607  0 17:59 pts/0    00:00:00 xsltproc /usr/share/cluster/relaxng/ra2rng.xsl -
root     10707 10705  0 17:59 pts/0    00:00:00 sh -c corosync-quorumtool -s 2>&1 | grep -E "Quorate:|Cannot connect to quorum service"
root     10708 10707  0 17:59 pts/0    00:00:00 corosync-quorumtool -s
root     10709 10707  0 17:59 pts/0    00:00:00 grep -E Quorate:|Cannot connect to quorum service

 kill 10709 10708 10707 10706 10705 10607 10605
allowed yum to continue.

Possibly related to Bug 702621 so this may be a no-op.

Comment 1 Fabio Massimo Di Nitto 2011-09-07 03:57:08 UTC
*** Bug 736200 has been marked as a duplicate of this bug. ***

Comment 2 Fabio Massimo Di Nitto 2011-09-07 03:59:58 UTC
Is cman running during the update?

Comment 3 Jerry Amundson 2011-09-07 04:51:46 UTC
(In reply to comment #2)
> Is cman running during the update?

Too late to know. Updates applied, System rebooted. Sorry.

Comment 4 Fabio Massimo Di Nitto 2011-09-07 06:39:19 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Is cman running during the update?
> 
> Too late to know. Updates applied, System rebooted. Sorry.

I can´t reproduce it here on F15. Either by doing a normal update (with cman NOT running) or a random one with cman running (unsupported).

Please feel free to reopen if you hit this issue again and if possible give us time to collect information.


Note You need to log in before you can comment on or make changes to this bug.