Bug 736227 - xulrunner-1.9.2.20-3.el5_7 depends on non existing nspr package
Summary: xulrunner-1.9.2.20-3.el5_7 depends on non existing nspr package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xulrunner
Version: 5.7
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 05:46 UTC by Kalle Kiviaho
Modified: 2018-11-14 10:37 UTC (History)
2 users (show)

Fixed In Version: RHSA-2011-1282
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-03 10:19:08 UTC


Attachments (Terms of Use)

Description Kalle Kiviaho 2011-09-07 05:46:23 UTC
Description of problem:
xulrunner-devel package has depencies for nspr 4.8.8, nspr 4.8.6 is current

Version-Release number of selected component (if applicable):
xulrunner-1.9.2.20-3.el5_7
xulrunner-devel-1.9.2.20-3.el5_7

How reproducible:
Always

Steps to Reproduce:
1. Update to the mentioned version
2. pkg-config --cflags libxul-embedding

  
Actual results:
# pkg-config --cflags libxul-embedding
Package 'libxul-embedding' requires 'nspr >= 4.8.8' but version of NSPR is 4.8.6

Expected results:
# pkg-config --cflags libxul-embedding
-DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4

Additional info:

Comment 1 Martin Stransky 2011-10-21 13:59:51 UTC
It's still here, xulrunner-1.9.2.23-1.el5_7. We have to remove nspr-4.8.8 from brew build root next time.

Comment 2 Martin Stransky 2011-11-03 10:19:08 UTC
nspr 4.8.8 is a part of https://rhn.redhat.com/errata/RHSA-2011-1282.html


Note You need to log in before you can comment on or make changes to this bug.