Bug 736248 - "Oh no! Something has gone wrong" after traversing the Activities button in a gnome3 session
Summary: "Oh no! Something has gone wrong" after traversing the Activities button in a...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 07:09 UTC by Joachim Backes
Modified: 2011-10-13 07:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 07:20:10 UTC


Attachments (Terms of Use)
~/.xsession-errors (4.56 KB, application/octet-stream)
2011-09-07 07:09 UTC, Joachim Backes
no flags Details
The actual updates (from yum.log) (4.57 KB, application/octet-stream)
2011-09-07 07:12 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2011-09-07 07:09:23 UTC
Created attachment 521805 [details]
~/.xsession-errors

Description of problem:

This happens very often:

After the todays morning updates (sep 07)  having a heavy problem with gnome-shell-sessions:

Each time I traverse the Activities button (screen top left), my gnome
session dies with "Oh no, something has gone wrong...". I can reproduce this!
It seems it has nothing to do with installed gnome-shell-extensions, because if I remove all extensions, I have still this behaviour.

Creating a new user, this user shows the "Avctivities" drop down menu
properly and starts the app if clicking on it's icon.

But if I change for this new user the window theme by gnome-tweak-tool
from default to Clearlooks (for example), then the gnome session crashes mostly 
too for this new user. By resetting the window theme I get rid from this
bug.

It seems something in my homedirectory is the culprit for this, but what?

Version-Release number of selected component (if applicable):
gnome-shell-3.1.4-2.gite7b9933.fc16.x86_64

How reproducible:
Very often, but not always

Steps to Reproduce:
1.Login into a gnome session
2.Touch the Activities button
3.
  
Actual results:
The session dies with "Oh no. Something has gone wrong"

Expected results:
The session continues

Additional info:

1. I saw some errors in ~/.xsession-errors. I'll attach it
2. There seems to be a weird "self-healing" effect, because after some time (login, crash, login again, multiple times) I can click the Activities button and show the correspondent menu (the session continues)

Comment 1 Joachim Backes 2011-09-07 07:12:28 UTC
Created attachment 521806 [details]
The actual updates (from yum.log)

The updates of today causing my problem (excerpt from /var/log/yum.log)

Comment 2 Joachim Backes 2011-10-13 07:10:39 UTC
Getting rid of the described problems by one the todays updates:

Oct 13 08:19:06 Updated: imsettings-libs-1.2.5-3.fc16.x86_64
Oct 13 08:19:06 Updated: imsettings-gnome-1.2.5-3.fc16.x86_64
Oct 13 08:19:08 Updated: imsettings-1.2.5-3.fc16.x86_64

or

Oct 13 08:19:01 Updated: glibc-common-2.14.90-11.x86_64
Oct 13 08:19:05 Updated: glibc-2.14.90-11.x86_64
Oct 13 08:19:12 Updated: glibc-headers-2.14.90-11.x86_64
Oct 13 08:19:16 Updated: glibc-devel-2.14.90-11.x86_64
Oct 13 08:19:21 Updated: glibc-2.14.90-11.i686

Comment 3 Joachim Backes 2011-10-13 07:19:40 UTC
I want to withdraw comment #2 (wrong BZ#). My mistake!


Note You need to log in before you can comment on or make changes to this bug.