Bug 736312 - Provide help option for aeolus-check-services.
Summary: Provide help option for aeolus-check-services.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Maros Zatko
QA Contact: Aziza Karol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 11:23 UTC by Aziza Karol
Modified: 2012-05-15 20:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:38:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0586 normal SHIPPED_LIVE new packages: aeolus-configure 2012-05-15 22:31:34 UTC

Description Aziza Karol 2011-09-07 11:23:02 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Provide help option for aeolus-check-services
 ie# aeolus-check-services -h

currently when executed it list all the status of aeolus services.

what is the option for restarting all the aeolus services?

  
Expected results:


Additional info:
[root@dell-pe830-01 util]# rpm -qa  | grep aeolus
rubygem-aeolus-image-0.1.0-3.20110824113236git15b6922.fc15.noarch
aeolus-configure-2.0.2-2.20110830113535git906f985.fc15.noarch
aeolus-conductor-0.4.0-0.20110906160322gitef6e25d.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110906160322gitef6e25d.fc15.noarch
aeolus-all-0.4.0-0.20110906160322gitef6e25d.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110906160322gitef6e25d.fc15.noarch

Comment 1 Maros Zatko 2011-09-22 15:38:18 UTC
Sent to list for review

commit 2cc436791e25100530d61acfd6cef53572fb78d9
Author: Maros Zatko <mzatko@redhat.com>
Date:   Wed Sep 21 12:00:56 2011 +0200

    added usage to aeolus-restart-services

commit e7b46a9ded8d1e64dae782c363fc572eb9e2392d
Author: Maros Zatko <mzatko@redhat.com>
Date:   Wed Sep 21 11:59:41 2011 +0200

    added usage to aeolus-check-services

Comment 2 wes hayutin 2011-09-28 16:40:18 UTC
making sure all the bugs are at the right version for future queries

Comment 4 Aziza Karol 2011-10-31 10:53:56 UTC

[root@dell-pe1950-01 usr]# aeolus-check-services -h

Checking mongod ...
 Success: mongod (pid 3961) is running...

Checking iwhd ...
 Success: iwhd (pid  4123) is running...

Checking postgresql ...
 Success: postmaster (pid  3590) is running...

Checking httpd ...
 Success: httpd (pid  3385) is running...

Checking qpidd ...
 Success: qpidd (pid  3699) is running...

Checking deltacloud-core ...
 Success: deltacloud-core (pid  3674) is running...

Checking libvirtd ...
 Success: libvirtd (pid  3761) is running...

Checking aeolus-conductor ...
 Success: (pid  4036) is running...

Checking conductor-dbomatic ...
 Success: dbomatic (pid  4096) is running...

Checking imagefactory ...
 Success: imagefactory (pid  3890) is running...

Checking ntpd ...
 Success: ntpd (pid  8998) is running...





[root@dell-pe1950-01 usr]# aeolus-restart-services -h

Stoping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stoping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stoping aeolus-conductor ...
 Success: Shutting down aeolus-conductor: [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stoping deltacloud-core ...
[  OK  ]: Shutting down deltacloud-core: [  OK  ]

Stoping qpidd ...
 Success: Stopping Qpid AMQP daemon: [  OK  ]

Stoping httpd ...
 Success: Stopping httpd: [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stoping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stoping mongod ...
 Success: Stopping mongod: [  OK  ]

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting qpidd ...
 Success: Starting Qpid AMQP daemon: [  OK  ]

Starting deltacloud-core ...
[  OK  ]: Starting deltacloud-core: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
touch: missing file operand
Try `touch --help' for more information.
 Success: Starting aeolus-conductor: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
/usr/lib/python2.6/site-packages/oauth2/__init__.py:29: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]

Statusing mongod ...
 Success: mongod (pid 10990) is running...


Usage is not added for aeolus-check and aeolus-restart services.

[root@dell-pe1950-01 usr]# rpm -qa | grep  aeolus
aeolus-conductor-0.6.0-0.20111029030732git7410602.el6.noarch
rubygem-ZenTest-4.3.3-2.aeolus.el6.noarch
aeolus-all-0.6.0-0.20111029030732git7410602.el6.noarch
rubygem-aeolus-cli-0.1.0-3.20111028152758git7063136.el6.noarch
rubygem-aeolus-image-0.1.0-4.20111024205454git6b2b696.el6.noarch
aeolus-conductor-daemons-0.6.0-0.20111029030732git7410602.el6.noarch
aeolus-configure-2.3.0-0.20111028220920gitf01b051.el6.noarch
rubygem-rack-mount-0.7.1-3.aeolus.el6.noarch
aeolus-conductor-doc-0.6.0-0.20111029030732git7410602.el6.noarch
rubygem-arel-2.0.10-0.aeolus.el6.noarch

Comment 5 Maros Zatko 2011-12-14 16:10:43 UTC
Bugfix in:
commit 990f43d3002b2b06b98dba934c2b7114835ce6c8

Comment 6 Shveta 2011-12-26 15:14:48 UTC
[root@hp-bl260cg5-01 ~]# aeolus-restart-services -h
Usage: /usr/sbin/aeolus-restart-services [OPTION]
Restart Aeolus services.

  -h, --help  display this help and exit

To show status of aeolus services please use aeolus-check-services.
[root@hp-bl260cg5-01 ~]# aeolus-restart-services --help
Usage: /usr/sbin/aeolus-restart-services [OPTION]
Restart Aeolus services.

  -h, --help  display this help and exit

To show status of aeolus services please use aeolus-check-services.
[root@hp-bl260cg5-01 ~]# aeolus-check-services -h
Usage: /usr/bin/aeolus-check-services [OPTION]
Show status of Aeolus services.

  -h, --help  display this help and exit

To restart aeolus services please use aeolus-restart-services.
[root@hp-bl260cg5-01 ~]# aeolus-check-services --help
Usage: /usr/bin/aeolus-check-services [OPTION]
Show status of Aeolus services.

  -h, --help  display this help and exit

To restart aeolus services please use aeolus-restart-services.

Comment 8 errata-xmlrpc 2012-05-15 20:38:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0586.html


Note You need to log in before you can comment on or make changes to this bug.