Bug 736348 - kernel vmlinuz-2.6.40.4-5.fc15.x86_64 doesn't boot.
Summary: kernel vmlinuz-2.6.40.4-5.fc15.x86_64 doesn't boot.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 13:19 UTC by smithbrooklyn88
Modified: 2011-11-29 20:15 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-29 20:15:08 UTC


Attachments (Terms of Use)
messages (2.11 MB, image/jpeg)
2011-09-26 14:17 UTC, Marcel Poul
no flags Details

Description smithbrooklyn88 2011-09-07 13:19:53 UTC
Description of problem:
latest kernel upgrade will not boot

Version-Release number of selected component (if applicable):

vmlinuz-2.6.40.4-5.fc15.x86_64
How reproducible:
yum -y --skip-broken upgrade

Steps to Reproduce:
1.yum -y --skip-broken upgrade
2.reboot choose new kernel
3.pull your hair out unless you can boot kernel 2.6.40.3-0
  
Actual results:
system will not reboot have to choose kernel 2.6.40.3-0

Expected results:


Additional info:
error with Dracut stops system from booting

Comment 1 Patrick Pichon 2011-09-16 11:28:25 UTC
Same problem o myside.

I doing dmesg, I'm gettig an error o /dev/disk/by-uuid/1c51ab44-xxxxxx not found and which is my / (under RAID1)

Comment 2 Dave Jones 2011-09-19 19:58:11 UTC
make sure you have the latest updates for mdadm, device-mapper-libs and dracut installed, then remove and reinstall the kernel update.

Comment 3 Patrick Pichon 2011-09-19 20:01:29 UTC
Dave,

Excatly what I've done ... And indeed solved the problem

Comment 4 Dave Jones 2011-09-20 16:30:30 UTC
ok, the requires: were bumped in the spec file ready for the next update so this shouldn't happen again when that comes out.

Comment 5 Marcel Poul 2011-09-21 08:52:16 UTC
Same problem  as smithbrooklyn88,
Downloaded fedora live cd, made fresh install and updated all packages including kernel. After reboot, cannot boot into new kernel, something like strace program output shows up on my screen. I have to choose 2.6.38.6-26.rc1.fc15.x86_64 kernel to boot properly.

Comment 6 Marcel Poul 2011-09-22 15:11:02 UTC
To be more precise, I don't know if the problem is caused by dracut error, since I can't read trace output (too fast). I was wondering if there is a log file with that kind of error messages? If so, I can provide it.

Comment 7 Dave Jones 2011-09-22 18:25:15 UTC
Marcel, the ordering the updates are applied is currently broken. Follow the instructions in comment 2 and see if that fixes it for you.

Comment 8 Marcel Poul 2011-09-22 21:40:38 UTC
Dave,
It seems that it does not work for me. I check yum info for mdadm, device-mapper-libs and dracut and all packages are installed. Then tried yum update with the result, no packages to be updated. Then yum remove kernel-2.6.40.4, then yum update, kernel-2.6.40.4 was then reistalled. Computer restarted and tried to boot info new kernel - failed. (I do not have RAID)

Comment 9 Chuck Ebbert 2011-09-26 12:55:33 UTC
(In reply to comment #8)
> restarted and tried to boot info new kernel - failed. (I do not have RAID)

If you do not have RAID, then you are not hitting this bug, which is entirely about RAID disks not being available during boot.

I'm not sure what kind of trace output you're talking about that's scrolling by too fast to read, can you be more specific?

Comment 10 Marcel Poul 2011-09-26 14:13:46 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > restarted and tried to boot info new kernel - failed. (I do not have RAID)
> 
> If you do not have RAID, then you are not hitting this bug, which is entirely
> about RAID disks not being available during boot.
If so, then I'm sorry for misinterpreting the bug description.
> 
> I'm not sure what kind of trace output you're talking about that's scrolling by
> too fast to read, can you be more specific?
after I choose new kernel in grub menu. I will add attachment soon.

Comment 11 Marcel Poul 2011-09-26 14:17:09 UTC
Created attachment 524915 [details]
messages

I can see these messages, but not all of them as the output printing is too fast.

Comment 12 Josh Boyer 2011-11-29 20:15:08 UTC
Closing this bug out as the original issue was resolved.

Marcel, if you are still having problems on the 2.6.41.x updates for F15, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.