Bug 736357 - RHEVH 6.2 fails to mount lvs after installation
Summary: RHEVH 6.2 fails to mount lvs after installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 6.2
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 13:35 UTC by Mike Burns
Modified: 2011-12-06 19:27 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-2.0.2-0.6.gitcc6ba8c.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:27:26 UTC


Attachments (Terms of Use)
Patch (1.32 KB, patch)
2011-09-07 21:03 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Mike Burns 2011-09-07 13:35:51 UTC
Description of problem:
install succeeds successfully, but after reboot, login fails due to the config partition not being mounted

After failing to boot once, booted again with rootpw option to temporarily set a password for debugging

during boot process:

Setting up Logical Volume Management:   4 logical volume(s) in volume group "HostVG" now active
  /dev/mapper/HostVG-Swap: open failed: No such file or directory
  /dev/mapper/HostVG-Config: open failed: No such file or directory
  /dev/mapper/HostVG-Logging: open failed: No such file or directory
  /dev/mapper/HostVG-Data: open failed: No such file or directory
[  OK  ]


# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root              1032088    279908    741700  28% /
/dev/vda2               241965    126655    102818  56% /dev/.initramfs/live
/dev/vda2               241965    126655    102818  56% /live

# ls /dev/mapper
control


Version-Release number of selected component (if applicable):
any *pure* 6.2 build, not with hybrid repo

How reproducible:
Always

Steps to Reproduce:
1. Install using TUI
2. boot
3.
  
Actual results:
Can't login

Expected results:
All mount work correctly

Additional info:

Comment 1 Mike Burns 2011-09-07 13:38:37 UTC
The same occurs with autoinstall.  The above and the autoinstall tests were done on virtual machines using virtio disks.

Comment 2 Mike Burns 2011-09-07 13:50:05 UTC
LVM output of installed system

# pvs
  PV         VG     Fmt  Attr PSize PFree
  /dev/vda3  HostVG lvm2 a--  7.52g    0 
[root@localhost ~]# vgs
  VG     #PV #LV #SN Attr   VSize VFree
  HostVG   1   4   0 wz--n- 7.52g    0 
[root@localhost ~]# lvs
  LV      VG     Attr   LSize Origin Snap%  Move Log Copy%  Convert
  Config  HostVG -wi-a- 8.00m                                      
  Data    HostVG -wi-a- 3.27g                                      
  Logging HostVG -wi-a- 2.00g                                      
  Swap    HostVG -wi-a- 2.24g

Comment 3 Mike Burns 2011-09-07 15:40:17 UTC
I built a test image with the 6.1 version of lvm2 and device-mapper-multipath (not needed, no multipath in my scenario).  This did not have the same issue as the fully 6.2 version. 

During boot, we get messages like this:
 /dev/mapper/HostVG-Swap not set up by udev: Falling back to direct node creation.
  /dev/mapper/HostVG-Config not set up by udev: Falling back to direct node creation.
  /dev/mapper/HostVG-Logging not set up by udev: Falling back to direct node creation.
  /dev/mapper/HostVG-Data not set up by udev: Falling back to direct node creation.

This is expected since we remove the udev rule that creates them due to problems with devices containing spaces in their names.

Comment 4 Mike Burns 2011-09-07 21:03:44 UTC
Created attachment 522007 [details]
Patch

Comment 5 Mike Burns 2011-09-07 21:06:18 UTC
Spoke with LVM team.  A rule was disabled in lvm.conf for performance reasons.  A separate bug (bug 736486) was filed for the issues we were working around.  The rule that was disabled has been re-enabled in RHEV-H.  Once the related lvm bug is fixed, this change will be rolled back.

Comment 8 Mike Burns 2011-09-16 22:50:26 UTC
This bug needs a pure 6.2 build to be verified.  The option we're changing was set to 0 in previous releases.

Comment 11 Ying Cui 2011-10-13 03:13:56 UTC
Verified this bug on RHEV-H 6.2-20111010.2 build.
Test steps:
1. TUI install/autoinstall successful.
2. can login rhevh successful.
3. # pvs
  PV                VG     Fmt  Attr PSize   PFree
  /dev/cciss/c0d0p3 HostVG lvm2 a--  136.19g    0 
  # vgs
  VG     #PV #LV #SN Attr   VSize   VFree
  HostVG   1   4   0 wz--n- 136.19g    0 
  # lvs
  LV      VG     Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  Config  HostVG -wi-ao   8.00m                                      
  Data    HostVG -wi-ao 126.34g                                      
  Logging HostVG -wi-ao   2.00g                                      
  Swap    HostVG -wi-ao   7.84g

Comment 12 errata-xmlrpc 2011-12-06 19:27:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.