Bug 736385 - Subscription Assistant: Subscribe button is active when there is no selected subscription.
Summary: Subscription Assistant: Subscribe button is active when there is no selected ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: Entitlement Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738066 756082
TreeView+ depends on / blocked
 
Reported: 2011-09-07 14:57 UTC by Michael Stead
Modified: 2012-06-20 12:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 12:56:39 UTC


Attachments (Terms of Use)
subscription-assistant (190.28 KB, image/png)
2012-03-02 07:57 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0804 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2012-06-19 19:51:31 UTC
Red Hat Bugzilla 742033 None None None Never

Internal Links: 742033

Description Michael Stead 2011-09-07 14:57:31 UTC
Description of problem:
Subscribe button remains active when there is no subscription selected. 

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.96.8-1.git.22.6521906.el6.x86_64
subscription-manager-debuginfo-0.96.8-1.git.22.6521906.el6.x86_64
subscription-manager-gnome-0.96.8-1.git.22.6521906.el6.x86_64
subscription-manager-0.96.8-1.git.22.6521906.el6.x86_64

How reproducible:
always

Steps to Reproduce:
There are two ways this can be reproduced. They are slightly different and both should be addressed.

First:
1) Open Subscription Assistant
2) Click Check all - Ensure there are multiple subscriptions to choose from
3) Select a subscription
4) CTRL-click to unselect it.
5) Subscribe button remains active.

Second:
1) Open Subscription Assistant
2) Click Check all - Ensure there are multiple subscriptions to choose from
3) Select a subscription and click subscribe.
4) Notice there are no subscriptions selected, but the 'Subscribe' button remains active.
  
Actual results:
In both cases, the 'Subscribe' button remains active. Clicking it produces the following error in log file.

Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/subscription_assistant.py", line 553, in subscribe_button_clicked
    pool_id = model.get_value(tree_iter, self.subscriptions_store['pool_id'])
TypeError: iter must be a GtkTreeIter


Expected results:
Subscribe button should not be active unless there is a subscription selected.

Additional info:

Comment 5 Shwetha Kallesh 2012-03-02 07:56:18 UTC
Moving the bug to verified.

details in the attachment.

RPM used:

[root@dhcp201-162 rhsm]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.99.8-1.git.14.9d78e7f.el6.x86_64
subscription-manager-migration-data-1.12.1-1.git.4.7b6cf92.el6.noarch
subscription-manager-gnome-0.99.8-1.git.14.9d78e7f.el6.x86_64
subscription-manager-debuginfo-0.99.8-1.el6.x86_64
subscription-manager-0.99.8-1.git.14.9d78e7f.el6.x86_64
subscription-manager-migration-0.99.8-1.git.14.9d78e7f.el6.x86_64

Comment 6 Shwetha Kallesh 2012-03-02 07:57:16 UTC
Created attachment 567001 [details]
subscription-assistant

Comment 8 errata-xmlrpc 2012-06-20 12:56:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html


Note You need to log in before you can comment on or make changes to this bug.