Bug 73651 - rpm hang in pause()
rpm hang in pause()
Status: CLOSED DUPLICATE of bug 73134
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
null
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-07 15:37 EDT by Scott Lamb
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-09 07:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Lamb 2002-09-07 15:37:55 EDT
Description of Problem:

up2date hangs after installing a package. I believe the problem is in rpm.

Version-Release number of selected component (if applicable):

rpm-4.1-1.06
rpm-python-4.1-1.06
rhnlib-1.0-1
up2date-2.9.68-1

The rpm-4.1-1.06 is from <ftp://people.redhat.com/jbj/test-4.1>.

Attaching with gdb showed this:

#0  0x420ae557 in pause () from /lib/i686/libc.so.6
#1  0x4003688f in pause () from /lib/i686/libpthread.so.0
#2  0x400cbb38 in psmWait () from /usr/lib/librpm-4.1.so
#3  0x400cc0ee in runScript () from /usr/lib/librpm-4.1.so
#4  0x400cc73b in runInstScript () from /usr/lib/librpm-4.1.so
#5  0x400cec7e in rpmpsmStage () from /usr/lib/librpm-4.1.so
#6  0x400cdc31 in rpmpsmStage () from /usr/lib/librpm-4.1.so
#7  0x400cea89 in rpmpsmStage () from /usr/lib/librpm-4.1.so
#8  0x400eaf57 in rpmtsRun () from /usr/lib/librpm-4.1.so
#9  0x40091265 in rpmts_Run ()
   from /usr/lib/python2.2/site-packages/rpmmodule.so

My guess is this is related to the fix for bug 73134, since pause() is for
waiting on signals and the problem occurs with the test rpms to fix that bug. I
tried sending a SIGCHLD, no effect. There is no zombie child.

It was also unresponsive to SIGTERM. SIGINT killed it.
Comment 1 Gene Czarcinski 2002-09-09 07:41:22 EDT
I am seeing this more and more ... in -Fvh/-Uvh as well as -e.

Doing an strace -pNNNN shows it is in a loop.

What information should we collect to debug this condition.

This problem has been reported over and over and fixed over and over.  I am
concerned that this problem has been consistently present and not fixed.

Doing kill -9 for the process and then rm /var/lib/rpm/__* before rerunning has
resulted in rpm completing the desired task.
Comment 2 Jeff Johnson 2002-09-17 07:46:37 EDT

*** This bug has been marked as a duplicate of 73134 ***

Note You need to log in before you can comment on or make changes to this bug.