Bug 73653 - Truncated anaconda button when using Swedish
Truncated anaconda button when using Swedish
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-07 16:46 EDT by Christian Rose
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:53:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-09-07 16:46:29 EDT
Tested using null and Swedish.

#: ../iw/language_support_gui.py:214
msgid "Select Default _Only"
msgstr "Vdlj _endast standardalternativet"

When the above translation is displayed on a button, it get's cut (due to the
lack of space) so that only "lj _endast standardalternativ" is visible. I don't
see how to make this message shorter without making the wording worse, so I
think it would be great if the width of the button would adopt to the message size.
Comment 1 Michael Fulbright 2002-09-16 17:22:41 EDT
Alex do you have any ideas?
Comment 2 Alexander Larsson 2002-09-17 03:30:35 EDT
msf: Is there any way to make the button grow?

If not, i guess you could use "Valj endast standard", which is somewhat worse,
but should fit.
Comment 3 Michael Fulbright 2002-09-20 17:20:15 EDT
Thanks.
Comment 4 Michael Fulbright 2003-01-30 16:54:04 EST
Alex can we make the label in the button wrap on multiple lines? What if I use
pango markup on the label?
Comment 5 Alexander Larsson 2003-02-05 09:23:56 EST
You should be able to call gtk_label_set_line_wrap() on the child of the button.

Comment 6 Michael Fulbright 2003-02-06 12:51:38 EST
This works nicely.
Comment 7 Brent Fox 2003-05-25 10:53:48 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.