Bug 736642 - sound controls mixed up and Pluging headphones does not mute internal speaker anymore
Summary: sound controls mixed up and Pluging headphones does not mute internal speaker...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 10:46 UTC by Dag
Modified: 2011-10-26 18:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-26 18:25:13 UTC


Attachments (Terms of Use)

Description Dag 2011-09-08 10:46:15 UTC
Description of problem:
With kernel 2.6.38.8-35 x86_64 FC15, there is no problem when I plug a headphones' jack in : the internal speakers are muted and I can control each output correctly.

But since 2.6.40.xxx when I plug a headphones' jack in, I get sound on both internal and headphones.
There is no mean to mute speakers by volume control (PulseAudio) anymore.
Plus when I play with (un)muting in alsamixer it just mute or unmute "speakers" or "Master" or put "Speaker" level to 0dB it's really odd : volumes or mutes of some Outputs change as I play with some other outputs from the same sound card.
Booting back on 2.6.38.8-35 solves the problem.


Using Alsa mixer I could get a workaround :
- muting "speakers" output (it DOES mute the speakers)
- tuning the "speakers" volume to my needs (even if it's muted),
- unmuting "Headphones 2",
- and play a bit with those 3 controls and the Master volume and mute controls until I get no sound from speakers and sound on headphones' output.


It doesn't do that with 2.6.38 kernel.


How reproducible:
Always.

  
Actual results:
Sound control is all messed / mixed up.
Speakers are unmutable with PulseAudio volume control panel, I must play a bit with AlsaMixer to try to get what I want (speakers muted when headphones plugged in).


Expected results:
I have 2 headphones outputs and internal speakers :
- one of the two headphones output used to mute internal speakers when I connected a headphones' jack,
- the other headphones output did not mute speakers when a headphones' jack was plugged in (speakers and headphones work at the same time),

- selecting the right setting in the sound properties of pulseAudio used to control this as well (mute speakers and enable output jacks),


Additional info:

Comment 1 Dag 2011-09-10 12:18:39 UTC
I forgot to let some details :

lspci :
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

The first is "internal analog audio" and the second is HDMI.

If you need further details, just ask.

regards.

Comment 2 Josh Boyer 2011-10-14 15:51:56 UTC
Can you show the dmesg output for ALSA?  There have been a few fixes in the 3.1 kernel for the realtek codec used by hda in this area.  It might be worth testing the F16 Beta live image to see if the same problem still exists there.

Comment 3 Dag 2011-10-18 12:35:39 UTC
Hi,


Here is "grep -i ALSA /var/log/messages" (with 2.6.40.6-0.fc15.x86_64) :

Oct 17 19:20:16 asus17 pulseaudio[2541]: alsa-sink.c: ALSA nous a réveillé pour lire de nouvelles données à partir du périphérique, mais il n'y avait en fait rien à écrire !
Oct 17 19:20:16 asus17 pulseaudio[2541]: alsa-sink.c: Il s'agit très probablement d'un bogue dans le pilote ALSA « snd_hda_intel ». Veuillez rapporter ce problème aux développeurs d'ALSA.Nous avons été réveillés avec le jeu POLLOUT -- cependant un snd_pcm_avail() ultérieur a retourné 0 ou une autre valeur < min_avail.


and here is "dmesg | grep -i ALSA" :
[   31.063080] ALSA sound/pci/hda/hda_intel.c:1452 Enable delay in RIRB handling


I tried Fedora 16 Beta LiveCD and the problem is exactly the same (but no "ALSA" lines in the dmesg nor in /var/log/messages).


If you need more informations, feel free to ask. :)

regards

Comment 4 Dag 2011-10-18 12:56:42 UTC
Translation to english :

Oct 17 19:20:16 asus17 pulseaudio[2541]: alsa-sink.c: ALSA wakoe us up to read new data from device, but in fact there was nothing to write !
Oct 17 19:20:16 asus17 pulseaudio[2541]: alsa-sink.c: it is certainly a bug in ALSA driver "snd_hda_intel". Please report this problem to Alsa devceloppment team. We have been woken up with POLLOUT -- but a following snd_pcm_avail() returned 0 or an other value < min_avail.

regards

Comment 5 Dag 2011-10-26 18:25:13 UTC
Ok,

Problem solved.

Did this as root :
echo "options snd_hda_intel model=auto" >> /etc/modprobe.d/snd_hda_intel

Found it in 
http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt

Thanks and bye for now!


Note You need to log in before you can comment on or make changes to this bug.