Bug 736664 - NDIS Test 6.0 (priority) job failed on win2k8_32 & win2k8 R2
Summary: NDIS Test 6.0 (priority) job failed on win2k8_32 & win2k8 R2
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 11:42 UTC by Mike Cao
Modified: 2011-09-16 09:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-16 09:02:21 UTC


Attachments (Terms of Use)
CPK files for win2k8_32 (5.42 MB, application/x-zip-compressed)
2011-09-08 11:45 UTC, Mike Cao
no flags Details

Description Mike Cao 2011-09-08 11:42:38 UTC
Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1.15

How reproducible:


  
Actual results:
Child job "Start NDISTest Client" always failed (not sure 100%)


Additional info:
will attach win2k8_32 cpk for your information.

Comment 1 Mike Cao 2011-09-08 11:45:05 UTC
Created attachment 522097 [details]
CPK files for win2k8_32

Comment 3 Ronen Hod 2011-09-08 16:30:30 UTC
IIUC the problem is that a bridge erased the 3 QoS priority-bits. This can be a physical bridge (probably not the case) or a software (bridge, firewall ...) on the host. 
I asked mst for advice, and he looked into slot-2 10.66.73.35 (QE lab).
There was no need for 
"disable bridge netfilter"
since it was disabled already.
mst did:
"service iptables stop"
"rmmod ebtable_nat"
"rmmod ebtables"

If this is the right host then please try again after these changes. Otherwise, please repeat these changes on the relevant host(s) and try again.

If it doesn't solve the problem then we will probably need to run tcpdump on the host(s) to see where the bits were erased.

Thanks, Ronen.

Comment 4 Min Deng 2011-09-09 10:03:50 UTC
Hi Ronen,

   QE submit window 2008 32 bits and window 7 32 bits in WORKGROUP.And I will attach the results,please wait.

Thanks
Min

Comment 5 Min Deng 2011-09-09 11:20:51 UTC
The Latest testing results for windows 2008 32 bits,actually I also submitted a job in the domino.The job passed at last.

Thanks 
Min

Comment 6 dawu 2011-09-13 09:38:01 UTC
Hi Ronen,

I have tried win7-32 in work group environment, I followed mst did
"service iptables stop"
"rmmod ebtable_nat"
"rmmod ebtables"

job still failed,please refer to the attached of "win7-32 NDISTest6.0(priority).cpk" for details.

We will try again on win7-32 in Domain environment and update the result later.

Best Regards,
Dawn

Comment 7 Michael S. Tsirkin 2011-09-13 10:27:30 UTC
so, run tcpdump -w on host on both on tap devices and bridge
and compare them, see if qos has been modified.

Comment 8 Ronen Hod 2011-09-13 13:23:28 UTC
(In reply to comment #6)
> Hi Ronen,
> 
> I have tried win7-32 in work group environment, I followed mst did
> "service iptables stop"
> "rmmod ebtable_nat"
> "rmmod ebtables"

The server lost these settings. We need a persistent setup

Revised instructions (should be persistent after boot too). Please also update your WHQL document:

Add the following 3 lines to /etc/sysctl.conf
 net.bridge.bridge-nf-call-ip6tables = 0
 net.bridge.bridge-nf-call-iptables = 0
 net.bridge.bridge-nf-call-arptables = 0
run "sysctl -p /etc/sysctl.conf"

"service iptables stop"
"chkconfig iptables off"

"rmmod ebtable_nat"
"rmmod ebtables"
Add ebtables_nat and ebtables to /etc/modprobe.d/blacklist.conf

> 
> job still failed,please refer to the attached of "win7-32
> NDISTest6.0(priority).cpk" for details.

I only see the attachment from Sep 8, but it probably isn't relevant since the firewall was probably active.

> 
> We will try again on win7-32 in Domain environment and update the result later.
> 
> Best Regards,
> Dawn

Comment 9 dawu 2011-09-14 02:51:49 UTC
(In reply to comment #8)
> (In reply to comment #6)
> > Hi Ronen,
> > 
> > I have tried win7-32 in work group environment, I followed mst did
> > "service iptables stop"
> > "rmmod ebtable_nat"
> > "rmmod ebtables"
> 
> The server lost these settings. We need a persistent setup
> 
> Revised instructions (should be persistent after boot too). Please also update
> your WHQL document:
> 
> Add the following 3 lines to /etc/sysctl.conf
>  net.bridge.bridge-nf-call-ip6tables = 0
>  net.bridge.bridge-nf-call-iptables = 0
>  net.bridge.bridge-nf-call-arptables = 0
> run "sysctl -p /etc/sysctl.conf"
> 
> "service iptables stop"
> "chkconfig iptables off"
> 
> "rmmod ebtable_nat"
> "rmmod ebtables"
> Add ebtables_nat and ebtables to /etc/modprobe.d/blacklist.conf
> 
> > 
> > job still failed,please refer to the attached of "win7-32
> > NDISTest6.0(priority).cpk" for details.
> 
> I only see the attachment from Sep 8, but it probably isn't relevant since the
> firewall was probably active.
> 
> > 
> > We will try again on win7-32 in Domain environment and update the result later.
> > 
> > Best Regards,
> > Dawn

Hi Ronen,

According to your revised instructions we will try this again with the new driver (virtio-win-prewhql-0.1.16) with firewall turning off, and update the result later.
We will also update the WHQL document, thanks for your reminding.

Best Regards,
Dawn

Comment 10 dawu 2011-09-14 08:14:40 UTC
Hi Ronen,

I have tried win7-32 in Domain environment for 2 times with the new driver (virtio-win-prewhql-0.1.16) and set the environment according to your revised instruction:

Add the following 3 lines to /etc/sysctl.conf
 net.bridge.bridge-nf-call-ip6tables = 0
 net.bridge.bridge-nf-call-iptables = 0
 net.bridge.bridge-nf-call-arptables = 0
run "sysctl -p /etc/sysctl.conf"

"service iptables stop"
"chkconfig iptables off"

"rmmod ebtable_nat"
"rmmod ebtables"
Add ebtables_nat and ebtables to /etc/modprobe.d/blacklist.conf

From guest, I disabled firewall. Job passed without any error, looks like win2k8-32 and win7-32 can pass in domain environment easily, I'll try these 2 guests with fresh system in work group environment with the instruction you told me and update the result later.

Best Regards,
Dawn

Comment 11 dawu 2011-09-16 08:41:45 UTC
(In reply to comment #10)
> Hi Ronen,
> 
> I have tried win7-32 in Domain environment for 2 times with the new driver
> (virtio-win-prewhql-0.1.16) and set the environment according to your revised
> instruction:
> 
> Add the following 3 lines to /etc/sysctl.conf
>  net.bridge.bridge-nf-call-ip6tables = 0
>  net.bridge.bridge-nf-call-iptables = 0
>  net.bridge.bridge-nf-call-arptables = 0
> run "sysctl -p /etc/sysctl.conf"
> 
> "service iptables stop"
> "chkconfig iptables off"
> 
> "rmmod ebtable_nat"
> "rmmod ebtables"
> Add ebtables_nat and ebtables to /etc/modprobe.d/blacklist.conf
> 
> From guest, I disabled firewall. Job passed without any error, looks like
> win2k8-32 and win7-32 can pass in domain environment easily, I'll try these 2
> guests with fresh system in work group environment with the instruction you
> told me and update the result later.
> 
Tried on win7-32 in work group environment, this job passed without any error and all guests also passed in domain environment.

Best Regards,
Dawn

> Best Regards,
> Dawn

Comment 12 Mike Cao 2011-09-16 09:02:21 UTC
Close this one according to comment #11.

Comment 13 Mike Cao 2011-09-16 09:02:48 UTC
Close this one according to comment #11.


Note You need to log in before you can comment on or make changes to this bug.