Bug 736671 - which: no dmsetup in (/sbin:/bin:/usr/sbin:/usr/bin)
Summary: which: no dmsetup in (/sbin:/bin:/usr/sbin:/usr/bin)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 691780 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-08 11:55 UTC by Michal Kovarik
Modified: 2011-12-06 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 16:48:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1521 normal SHIPPED_LIVE dracut bug fix and enhancement update 2011-12-06 00:50:19 UTC

Description Michal Kovarik 2011-09-08 11:55:13 UTC
Description of problem:
When installing a system with minimal package set selected during the install,
following message is shown in /root/install.log:
...
Installing rt61pci-firmware-1.2-7.el6.noarch
Installing zd1211-firmware-1.4-4.el6.noarch
Installing rootfiles-8.1-6.1.el6.noarch
which: no dmsetup in (/sbin:/bin:/usr/sbin:/usr/bin)
ldd: missing file arguments
Try `ldd --help' for more information.
*** FINISHED INSTALLING PACKAGES ***

How reproducible:
always

Steps to Reproduce:
1. install RHEL6.1 with minimal package set
2. check install.log
3.
  
Actual results:
which: no dmsetup in (/sbin:/bin:/usr/sbin:/usr/bin)
ldd: missing file arguments
Try `ldd --help' for more information.

Expected results:
no errors

Additional info:
Very similar bug 732686

Comment 1 Michal Kovarik 2011-09-09 09:08:31 UTC
Steps to Reproduce:
1. start RHEL6.2-20110907.1 installation
2. proceed to the partitioning screen and select Create Custom Layout
3. create layout without LVM
4. finish the installation using minimal package set


Version-Release number of selected component (if applicable):
dracut-004-234.el6

Comment 2 RHEL Product and Program Management 2011-09-19 11:10:38 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 3 Harald Hoyer 2011-09-20 15:46:11 UTC
If you create a LVM layout, you really need to install
package lvm2, which requires 
device-mapper-libs, which requires 
device-mapper, 
and /sbin/dmsetup is in device-mapper.

Comment 5 Jan Stodola 2011-10-11 13:46:51 UTC
Tested with minimal package set on s390x and x86_64, LVM was not used. No errors in install.log found.

[root@kvm-guest-03 ~]# rpm -qa | wc -l
224

[root@kvm-guest-03 ~]# mount
/dev/sda2 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

[root@kvm-guest-03 ~]# grep -v ^Installing /root/install.log
warning: libgcc-4.4.6-3.el6.x86_64: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
warning: setup-2.8.14-13.el6.noarch: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
*** FINISHED INSTALLING PACKAGES ***

[root@kvm-guest-03 ~]# rpm -q dracut
dracut-004-247.el6.noarch

Moving to VERIFIED.

Comment 6 errata-xmlrpc 2011-12-06 16:48:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1521.html


Note You need to log in before you can comment on or make changes to this bug.