Bug 736682 - snapshot-create can not work
Summary: snapshot-create can not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Eric Blake
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 638510
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-08 12:23 UTC by weizhang
Modified: 2011-12-06 11:28 UTC (History)
9 users (show)

Fixed In Version: libvirt-0.9.4-11.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:28:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description weizhang 2011-09-08 12:23:40 UTC
Description of problem:
snapshot-create can not work
# virsh snapshot-create qcow2
error: argument unsupported: unable to handle disk requests in snapshot


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.185.el6.x86_64
libvirt-0.9.4-10.el6.x86_64
kernel-2.6.32-193.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. create a guest with qcow2 img
2. do # virsh snapshot-create qcow2
  
Actual results:
error: argument unsupported: unable to handle disk requests in snapshot

Expected results:
snapshot create successfully

Additional info:
snapshot-create can work well on libvirt-0.9.4-7, so it is a regression bug, it doesn't work since libvirt-0.9.4-8

Comment 1 Eric Blake 2011-09-08 12:40:33 UTC
I'm looking into it now.

Comment 2 Eric Blake 2011-09-08 13:19:14 UTC
Upstream patch: https://www.redhat.com/archives/libvir-list/2011-September/msg00395.html

Comment 6 weizhang 2011-09-09 02:53:23 UTC
verify pass on 
qemu-kvm-0.12.1.2-2.185.el6.x86_64
kernel-2.6.32-193.el6.x86_64
libvirt-0.9.4-11.el6.x86_64


# virsh snapshot-create foo 
Domain snapshot 1315536642 created

# virsh snapshot-list foo
 Name                 Creation Time             State
------------------------------------------------------------
 1315536642           2011-09-09 10:50:42 +0800 running

Comment 7 errata-xmlrpc 2011-12-06 11:28:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.