Bug 736683 - Installation script calls tardlink instead of hardlink, resulting in a bunch of "tardlink: command not found" errors
Summary: Installation script calls tardlink instead of hardlink, resulting in a bunch ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 2.0
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Red Hat Real Time Maintenance
QA Contact: David Sommerseth
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 12:23 UTC by Jeff Needle
Modified: 2016-05-22 23:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to a typographical mistake in the code, the kernel-rt installation attempts to call "tardlink" instead of "hardlink" and the installation returns multiple "tardlink: command not found" errors if the hardlink package is installed. However, the installation finishes successfully.
Clone Of:
Environment:
Last Closed: 2012-02-07 22:29:40 UTC


Attachments (Terms of Use)

Description Jeff Needle 2011-09-08 12:23:57 UTC
Description of problem:

On a system with the hardlink package installed, logic in the postinstall attempts to hardlink some files, but due to a typo, calls "tardlink".  This results in 

/var/tmp/rpm-tmp.FKBb1Y: line 9: tardlink: command not found

repeated 14840 times, which is ugly, at best.

Version-Release number of selected component (if applicable):
kernel-rt-*-2.6.33.9-rt31.75.el6rt.x86_64

How reproducible:

100%

Steps to Reproduce:
1. yum install hardlink
2. yum install kernel-rt
3. watch
  
Actual results:
Zillions of errors

Expected results:
No errors

Additional info:
After discussion, the hardlink logic was deemed to not be useful and should be removed completely, which will certainly fix the typo.

Comment 1 Eva Kopalova 2011-09-09 14:08:16 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a typographical mistake in the code, the kernel-rt installation attempts to call "tardlink" instead of "hardlink" and the installation returns multiple "tardlink: command not found" errors if the hardlink package is installed. However, the installation finishes successfully.

Comment 2 Clark Williams 2012-02-07 22:29:40 UTC
Fixed in current release


Note You need to log in before you can comment on or make changes to this bug.