Bug 736688 - can't register rhev-h to rhev-m
Summary: can't register rhev-h to rhev-m
Keywords:
Status: CLOSED DUPLICATE of bug 735932
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 12:30 UTC by Mike Burns
Modified: 2016-04-18 06:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-08 12:40:54 UTC


Attachments (Terms of Use)

Description Mike Burns 2011-09-08 12:30:02 UTC
Description of problem:
From vds_bootstap log

Thu, 08 Sep 2011 01:20:26 ERROR    Traceback (most recent call last):
  File "/usr/share/vdsm-reg/vdsm-gen-cert", line 80, in main
    CSR(subject, random_num, orgName).runTest()
  File "/usr/share/vdsm-reg/vdsm-gen-cert", line 62, in runTest
    deployUtil.createCSR(self.orgName, self.subject, self.random_num,
self.tsDir, self.VDSMKEY, self.DHKEY)
  File "/usr/share/vdsm-reg/deployUtil.py", line 1149, in createCSR
  File "/usr/share/vdsm-reg/deployUtil.py", line 346, in getOSVersion
IOError: [Errno 2] No such file or directory: '/etc/fedora-release'

Thu, 08 Sep 2011 01:20:26 ERROR    Usage: vdsm-gen-cert [-O
organizationName] <subject> <random_num>
Thu, 08 Sep 2011 01:20:26 DEBUG    <BSTRAP component='RHEV_INSTALL'
status='FAIL'/>


From analysis by Alan

Change is from bd6ec2a5e89b4693193d2561d462280418aa76aa
BZ#735932 vds_bootstrap: do not require and do not use redhat-lsb

+    for f in ('/etc/rhev-hypervisor-release', '/etc/redhat-release',
+              '/etc/fedora-release'):

Don't need this loop, just open /etc/system-release - it's a symlink to the appropriate file on all platforms we support.

+        except OSError:
+            pass

This didn't cach IOError :)


Version-Release number of selected component (if applicable):
Found using latest git repo, but present in 4.9-98

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dan Kenigsberg 2011-09-08 12:35:52 UTC
http://gerrit.usersys.redhat.com/916

Comment 2 Dan Kenigsberg 2011-09-08 12:40:54 UTC

*** This bug has been marked as a duplicate of bug 735932 ***


Note You need to log in before you can comment on or make changes to this bug.