Bug 736711 - [abrt] ibus-1.3.99.20110817-3.fc16: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: 在路径 org.freedesktop.IBus.InputContext 的对象上没有 /org/freedesktop/IBus/InputContext_2 接口
[abrt] ibus-1.3.99.20110817-3.fc16: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:a4054f29056a8e5037b1db997ee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-08 09:27 EDT by bsfmig
Modified: 2011-11-07 02:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-07 02:10:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bsfmig 2011-09-08 09:27:36 EDT
abrt version: 2.0.5
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        Switching between IMEs.
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         3.1.0-0.rc4.git0.0.fc16.x86_64
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: 在路径 org.freedesktop.IBus.InputContext 的对象上没有 /org/freedesktop/IBus/InputContext_2 接口
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           Thu Sep  8 21:26:58 2011
uid:            1000
username:       poo

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: 在路径 org.freedesktop.IBus.InputContext 的对象上没有 /org/freedesktop/IBus/InputContext_2 接口
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 653, in __status_icon_activate_cb
:    menu = self.__create_im_menu()
:  File "/usr/share/ibus/ui/gtk/panel.py", line 610, in __create_im_menu
:    if self.__focus_ic == None or not self.__focus_ic.is_enabled():
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 264, in is_enabled
:    return self.__context.IsEnabled()
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.UnknownMethod: 在路径 org.freedesktop.IBus.InputContext 的对象上没有 /org/freedesktop/IBus/InputContext_2 接口
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x2657050>
:args: ()
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_2')
:timeout: -1.0
:signature: None
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x2765ba0>
:method: 'IsEnabled'
Comment 1 fujiwara 2011-09-12 05:55:58 EDT
I cannot reproduce your problem.
Do you still see this problem?

Note You need to log in before you can comment on or make changes to this bug.