Bug 736827 - kernel bug in btrfs
Summary: kernel bug in btrfs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Bacik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 19:21 UTC by Jan Vlug
Modified: 2012-06-06 19:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-06 19:18:34 UTC


Attachments (Terms of Use)
dmesg with kernel bug messages (16.79 KB, text/plain)
2011-09-08 19:21 UTC, Jan Vlug
no flags Details

Description Jan Vlug 2011-09-08 19:21:53 UTC
Created attachment 522186 [details]
dmesg with kernel bug messages

Description of problem:
When I try to make a backup to a 2T external USB disk, I sometimes get kernel bugs.

Version-Release number of selected component (if applicable):
2.6.40.4-5.fc15.x86_64

How reproducible:
Just happens now and then.

Steps to Reproduce:
1. rdiffbackup to external btrfs disk.
  
Actual results:
See a bug message.

Expected results:
No bugs.

Additional info:
See attached dmesg output with bug messages.

Comment 1 Josef Bacik 2011-09-12 14:50:22 UTC
Somethings gone wrong with your drive

[ 6018.455644] sd 7:0:0:0: [sdd] Unhandled error code
[ 6018.455649] sd 7:0:0:0: [sdd]  Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[ 6018.455654] sd 7:0:0:0: [sdd] CDB: Read(10): 28 00 03 ab b7 10 00 00 08 00
[ 6018.455666] end_request: I/O error, dev sdd, sector 61585168
[ 6018.457426] lost page write due to I/O error on sdd1
[ 6018.457464] lost page write due to I/O error on sdd1
[ 6018.457492] lost page write due to I/O error on sdd1
[ 6018.457500] btrfs: 1 errors while writing supers

And we barely handle corrupt metadata well, much less IO errors in critical paths :).


Note You need to log in before you can comment on or make changes to this bug.