Bug 736850 - Change drop to shell option in Config TUI to make it less visible
Summary: Change drop to shell option in Config TUI to make it less visible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 20:56 UTC by Perry Myers
Modified: 2011-12-06 19:27 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.5.git83340dd.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:27:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Perry Myers 2011-09-08 20:56:54 UTC
Current Functionality:
  Install TUI
     F2 from ANY screen will immediately drop to shell (no warning)
     If install fails, 'view log' screen will be shown.  There is no option
     to drop to shell, but F2 still works as above (no warning)

  Config TUI
     F2 from ANY screen will go to Support Menu screen which will show several
     log files, and provides an option to Drop to Shell.  When this is selected
     a warning message is shown (i.e. don't do this w/o support)

Desired Functionality:
Make 'Drop to Shell' consistent between both install and config TUIs, and separate from the View Log screen

  Install TUI
     Only change here is to show a warning when pressing F2 prior to dropping to 
     shell
  
  Config TUI
     Change Support Menu to be F10 (why F10 instead of F3?  So people don't fat 
     finger and hit F2 by accident)
     Remove Drop to Shell option from Support Menu
     Make sure warning message is shown whenever F2 (Drop to Shell) is pressed

Comment 5 Guohua Ouyang 2011-09-13 02:26:03 UTC
Tested on 6.2-0.16.2:
1. Install TUI
   press F2 show a warning prior to dropping to shell.  (OK)

2. Config TUI
   It show a message "Press F10 For Support Menu" at the bottom, press F10 can view log files.  (OK)
   press F2 show a warning prior to dropping to shell. (OK)

But I have two things need to be confirmed before close this bug:
1. why F10 means support menu? it only show log files. However, F2 show a warning with title "Support Shell", which seems more suitable for support menu, and users can do more action after drop to shell, include view logs.  so how about show "Press F10 to view logs" instead of "Press F10 For Support Menu".
2. no message prompt user how to drop to shell, should we also have a prompt message like F10?

if the two questions are ok, I can close this bug.

Comment 6 Alan Pevec 2011-09-13 16:40:50 UTC
(In reply to comment #5)
Shell access on RHEV-H is not supported, hence we don't display it.
Normally, log files should be enough for debugging and only when instructed by GSS, customer will be asked to use F2 to access shell for further debugging.

Comment 7 Perry Myers 2011-09-13 16:59:48 UTC
(In reply to comment #6)
> (In reply to comment #5)
> Shell access on RHEV-H is not supported, hence we don't display it.
> Normally, log files should be enough for debugging and only when instructed by
> GSS, customer will be asked to use F2 to access shell for further debugging.

Right, other thing is that right now F10 says "Support Menu" and it is true that we only have log viewing in that menu right now, but I can think that we will want to add additional items to that support menu other than just viewing logs in the future (for example, a way to generate a sosreport and transfer it to another host, etc)

Comment 8 Guohua Ouyang 2011-09-14 01:33:39 UTC
ok, thanks for the explaining, set the bug status to be verified now.

Comment 9 errata-xmlrpc 2011-12-06 19:27:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.