Bug 736890 - boost needs rebuild against icu-4.8.1
Summary: boost needs rebuild against icu-4.8.1
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 01:20 UTC by Jens Petersen
Modified: 2013-08-09 05:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 14:43:07 UTC


Attachments (Terms of Use)

Description Jens Petersen 2011-09-09 01:20:15 UTC
Description of problem:
This week icu was updated in Rawhide to 4.8.1.
Currently rawhide boost (inherited from f16) is linked
against icu-4.6.  So currently boost is broken in rawhide.

Packages that BR boost can't currently be built for f17:
eg http://koji.fedoraproject.org/koji/taskinfo?taskID=3333451

Version-Release number of selected component (if applicable):
boost-1.47.0-3.fc16

How reproducible:

Steps to Reproduce:
1. Try to build package that depends on boost in dist-rawhide.
  
Actual results:
DEBUG util.py:247:  Error: Package: boost-graph-1.47.0-3.fc16.x86_64 (build)
DEBUG util.py:247:             Requires: libicuuc.so.46()(64bit)
DEBUG util.py:247:  Error: Package: boost-regex-1.47.0-3.fc16.x86_64 (build)
DEBUG util.py:247:             Requires: libicuuc.so.46()(64bit)
DEBUG util.py:247:  Error: Package: boost-regex-1.47.0-3.fc16.x86_64 (build)
DEBUG util.py:247:             Requires: libicui18n.so.46()(64bit)
DEBUG util.py:247:  Error: Package: boost-graph-1.47.0-3.fc16.x86_64 (build)
DEBUG util.py:247:             Requires: libicui18n.so.46()(64bit)

Expected results:
build to succeed

Additional info:
Hopefully just a simple rebuild is sufficient?

Comment 1 Petr Machata 2011-09-09 14:43:07 UTC
I rebuilt boost.  Thanks for heads-up.


Note You need to log in before you can comment on or make changes to this bug.