Bug 73692 - ide-scsi locks up system after scsi abort/timeout
ide-scsi locks up system after scsi abort/timeout
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-08 19:00 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-08 19:00:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
I'm trying to get ide-scsi to work on my CDRW.  Whether I use ide-scsi
as a module and allow modprobe to do the loading, or have ide-scsi, sg, sr_mod 
and mod_scsi compiled into the kernel, the result is the following:
SCSI subsystem driver Revision: 1.00
scsi0: SCSI host adapter emulation for IDE ATAPI devices
scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id
0 lun 0 Inquiry 00 00 00 ff 00
And the system locks up.

Here is the hardware configuration:
IDE0/master = 40GB IBM Deskstar 60GXP
IDE0/slave = 40GB IBM Deskstar 60GXP
IDE1/master = Asus 50x CDROM
IDE1/slave = Sony CRX145E CDRW 
mobo is MSI K7T266 Pro2 (ATA100) with Athlon XP2000+

I've tried setting the CDRW as master to the CDROM but still doesn't work.  I 
also tried adding "options ide-cd ignore=hdd" to /etc/modules.conf which only 
allowed the system to not lock up when booting as long as I didn't pass in 
hdd=ide-scsi at boot time.

Also, the installer would hang after reaching "Uniform CDROM driver Revision 
3.12"  To get around this, I had to type "linux hdd=ide-scsi" for the installer 
to work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
A(1).Use ide-scsi as module and pass "hdd=ide-scsi" as a boot param - system 
locks up when rc.sysinit executes "modprobe ide-scsi"

B(1).Use ide-scsi as module, do NOT pass "hdd=ide-scsi" as a boot param and 
allow system to boot up.
B(2).Add "hdd=ide-scsi" to /etc/modules.conf
B(3).Type "modprobe -v -n ide-scsi" to see what modules are being installed by 
insmod (scsi_mod then ide-scsi).
B(4).Manually install scsi_mod module with insmod which succeeds
B(5).Manuall install ide-scsi modules which fails with:
scsi : aborting command due to timeout : pid 231, scsi1, channel 0, id 0, lun 0 
Inquiry 00 00 00 ff 00

C(1).Compile a new kernel without ide-cd at all and compiling ide-scsi, sg, 
sr_mod and mod_scsi into the kernel.
C(2).Install new kernel
C(3).Boot into new kernel which results in freezing the system with the same 
scsi timeout error noted above. 

Actual Results:  System totally locked up.

Expected Results:  ide-scsi should have been loaded for hdd.

Additional info:
Comment 1 Need Real Name 2002-09-08 19:59:26 EDT
Updated sys configuration:
IDE0/master = 40GB IBM Deskstar 60GXP  (hda)
IDE0/slave = Asus 50x CDROM   (hdb)
IDE1/master = 40GB IBM Deskstar 60GXP   (hdc)
IDE1/slave = Sony CRX145E CDRW   (hdd)

I added some debugging statements to /etc/rc.d/rc.sysinit and discovered that 
the hdparm is causing the system to hang when not setting hdd=ide-scsi.
The command in rc.sysinit locking up the system is:
hdparm -d0 /dev/hdb
Comment 2 Bugzilla owner 2004-09-30 11:39:54 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.