Bug 736925 - SELinux is preventing /sbin/load_policy from read, write access on the chr_file load.
Summary: SELinux is preventing /sbin/load_policy from read, write access on the chr_fi...
Keywords:
Status: CLOSED DUPLICATE of bug 736924
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:fd7695fd034...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 05:50 UTC by Renich Bon Ciric
Modified: 2011-09-09 07:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 07:50:11 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2011-09-09 05:50:16 UTC
SELinux is preventing /sbin/load_policy from read, write access on the chr_file load.

*****  Plugin file (47.5 confidence) suggests  *******************************

If you think this is caused by a badly mislabeled machine.
Then you need to fully relabel.
Do
touch /.autorelabel; reboot

*****  Plugin file (47.5 confidence) suggests  *******************************

If you think this is caused by a badly mislabeled machine.
Then you need to fully relabel.
Do
touch /.autorelabel; reboot

*****  Plugin catchall (6.38 confidence) suggests  ***************************

If you believe that load_policy should be allowed read write access on the load chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep load_policy /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c
                              1023
Target Context                unconfined_u:object_r:file_t:s0
Target Objects                load [ chr_file ]
Source                        load_policy
Source Path                   /sbin/load_policy
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.86-7.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40.4-5.fc15.x86_64 #1 SMP
                              Tue Aug 30 14:38:32 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Fri 09 Sep 2011 12:47:45 AM CDT
Last Seen                     Fri 09 Sep 2011 12:47:45 AM CDT
Local ID                      4f629876-1268-4a64-8670-472fe48b7136

Raw Audit Messages
type=AVC msg=audit(1315547265.123:2424): avc:  denied  { read write } for  pid=13366 comm="load_policy" name="load" dev=dm-3 ino=30 scontext=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:file_t:s0 tclass=chr_file


type=AVC msg=audit(1315547265.123:2424): avc:  denied  { open } for  pid=13366 comm="load_policy" name="load" dev=dm-3 ino=30 scontext=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:file_t:s0 tclass=chr_file


type=SYSCALL msg=audit(1315547265.123:2424): arch=x86_64 syscall=open success=yes exit=EINTR a0=7fffa621e280 a1=2 a2=7fffa621e28d a3=2 items=0 ppid=13356 pid=13366 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm=load_policy exe=/sbin/load_policy subj=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 key=(null)

Hash: load_policy,load_policy_t,file_t,chr_file,read,write

audit2allow

#============= load_policy_t ==============
#!!!! The source type 'load_policy_t' can write to a 'chr_file' of the following types:
# user_devpts_t, user_tty_device_t, console_device_t, null_device_t, zero_device_t, devtty_t, initrc_devpts_t

allow load_policy_t file_t:chr_file { read write open };

audit2allow -R

#============= load_policy_t ==============
#!!!! The source type 'load_policy_t' can write to a 'chr_file' of the following types:
# user_devpts_t, user_tty_device_t, console_device_t, null_device_t, zero_device_t, devtty_t, initrc_devpts_t

allow load_policy_t file_t:chr_file { read write open };

Comment 1 Miroslav Grepl 2011-09-09 07:50:11 UTC

*** This bug has been marked as a duplicate of bug 736924 ***


Note You need to log in before you can comment on or make changes to this bug.