Bug 736932 - Starting up CIM server: cimserver not started: Bind failed: Failed to bind socket on port 5989: Address already in use (error code 98).
Summary: Starting up CIM server: cimserver not started: Bind failed: Failed to bind so...
Keywords:
Status: CLOSED DUPLICATE of bug 957233
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tog-pegasus
Version: 6.2
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-09-09 06:10 UTC by Pavel Holica
Modified: 2013-04-29 11:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-29 11:02:45 UTC


Attachments (Terms of Use)

Description Pavel Holica 2011-09-09 06:10:10 UTC
Description of problem:
Upgrading RHEL 6.1 GA ppc64 Server to RHEL6.2-20110907.1 ppc64 Server via yum shows error while restarting CIM Server.

Version-Release number of selected component (if applicable):
RHEL6.2-20110907.1 ppc64 Server
libvirt-cim-0.5.14-2.el6.ppc64

How reproducible:
always

Steps to Reproduce:
1. Install RHEL 6.1 GA ppc64 Server with all packages
2. Add yum repository for RHEL6.2-20110907.1 ppc64 Server
3. run yum upgrade
  
Actual results:
  Updating   : libvirt-cim-0.5.14-2.el6.ppc64                          373/1398 
Shutting down CIM server: [  OK  ]
[  OK  ]
Starting up CIM server: cimserver not started: Bind failed: Failed to bind socket on port 5989: Address already in use (error code 98).
[FAILED]
  Updating   : ...

Expected results:


Additional info:

Comment 1 Pavel Holica 2011-09-27 08:04:05 UTC
I've just seen this on RHEL6.2-20110923.3 x86_64 Client too, so setting platform to All.

Comment 8 Rita Wu 2012-01-12 05:49:15 UTC
Hello Pavel,

Would you pls kindly help to verify this bug when it's ON_QA? Since we cannot reproduce it per comment 4?

Thanks,
Rita

Comment 10 Pavel Holica 2012-01-12 06:23:14 UTC
Hello Rita,

I'll try to verify this bug by repeating process which detected this bug, since it happens randomly, but quite often.

Comment 12 yanbing du 2012-01-12 10:20:12 UTC
Retest this bug, and i can reproduce it.

Reinstall a RHEL6.1 host without the following packages:
libvirt, libvirt-cim, tog-segasus ans sblim-sfcb
Then yum install them manually, after all packages installed, start sblim-sfcb service first, then try to start libvirtd and tog-segasus, will get error as the bug described:
# service sblim-sfcb atart
# service libvirtd start
Starting libvirtd daemon: [  OK  ]
# service tog-pegasus start
tog-pegasus: Generating cimserver SSL certificates...[  OK  ]
Starting up CIM server: cimserver not started: Bind failed: Failed to bind socket on port 5989: Address already in use (error code 98).
[FAILED]

obviously, after start sblim-sfcb, port 5989 is used, and then start tog-pegasus which also need bind this port will fail.

Comment 13 Vitezslav Crhonek 2012-01-26 10:06:10 UTC
There's a way how to reproduce it without tog-pegasus vs. sblim-sfcb conflict. It happens when cimserver is killed with SIGKILL, so it doesn't terminate cimservermain process...

Comment 14 Daniel Veillard 2012-04-18 06:23:14 UTC
Okay, my analysis of this bugs is that's a tog-pegasus problem. Basically
it seems the script used on restart doesn't actually kill all the processes
associated to tog-pegasus, leading to the associated port still being in use
and failure to restart.

  I don't see how that would be specific to libvirt-cim, and unless
one can provide a scenario proving libvirt-cim fault, I think it's fair
to reassign the bug to tog-pegasus,

Daniel

Comment 16 Vitezslav Crhonek 2012-05-02 14:44:48 UTC
Sorry, I'm really not able to reproduce it. Script used on the restart seems to kill all the processes, when done manually (same command what is libvirt-cim executing in rpm post scriptlet), everything works fine:

# while true; do /etc/init.d/tog-pegasus condrestart; done

Can someone confirm that this is still happening? Pegasus was rebased between 6.1 and 6.2, maybe the issue was related to that state...

Comment 18 RHEL Product and Program Management 2012-07-10 07:57:44 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 19 RHEL Product and Program Management 2012-07-11 01:52:38 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 21 RHEL Product and Program Management 2012-12-14 08:00:36 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 22 Vitezslav Crhonek 2013-04-29 11:02:45 UTC
It's caused by abnormal termination.

*** This bug has been marked as a duplicate of bug 957233 ***


Note You need to log in before you can comment on or make changes to this bug.