Bug 736934 - pull command pulls translations in newly created po folder
pull command pulls translations in newly created po folder
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-09 02:22 EDT by Parag Nemade
Modified: 2013-03-03 21:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-14 02:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2011-09-09 02:22:00 EDT
Description of problem:
I have zanata.xml file under iok project as iok/po/zanata.xml. I tried to pull the translations using commands
zanata po pull --dstdir ./po
OR
zanata po pull --dstdir po
OR
zanata po pull --dstdir .

But all are creating one more folder called po under existing po folder


Version-Release number of selected component (if applicable):
zanata-python-client-1.2.4-1.fc15.noarch

How reproducible:
always

Steps to Reproduce:
1. checkout po files of iok project using above commands
2.
3.
  
Actual results:
zanata is pulling po files by creating po folder in existing po folder

Expected results:
zanata should pull po files in existing po folder

Additional info:
Comment 1 Parag Nemade 2011-09-12 05:16:06 EDT
I installed now zanata-python-client-1.3.0-1.fc15.noarch
when I tried to use 
zanata pull --transdir ./po
I got error as
error: The project type is unknown
Comment 2 Parag Nemade 2011-09-14 00:40:59 EDT
Ok. I got some help from Sandeep and looks following command is working for me.

zanata pull --project-type gettext iok

But , I have not seen this has been documented at http://zanata.org/docs/html-single/index.html#id685539
Comment 3 Ding-Yi Chen 2011-09-14 02:20:24 EDT
Seem like your problem has been resolved and documented, thus close this bug.
Comment 4 Parag Nemade 2011-09-14 02:50:37 EDT
actually I don't see above command is documented anywhere.

Note You need to log in before you can comment on or make changes to this bug.