Bug 736947 - mouse cursor does not work when managed-restore windows vm w/ spice multihead
Summary: mouse cursor does not work when managed-restore windows vm w/ spice multihead
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 07:09 UTC by zhe peng
Modified: 2014-07-06 19:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-17 15:04:12 UTC


Attachments (Terms of Use)

Description zhe peng 2011-09-09 07:09:37 UTC
Description of problem:
mouse cursor not worked when restore vm from save file with spice graphic console
only occur on windowsXP, win7, win2008,except win2003

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-11.el6
qemu-kvm-0.12.1.2-2.184.el6


How reproducible:
always

Steps to Reproduce:
1:Install a new Windows guest(win7,win2008,winxp) with spice graphic console
  2:start the guest
  3:click "virtual Machine"->"Shut Down"->"Save"
  4:the guest will saved.
  5:after save successfully,click "Restore"
  6:after guest restore

Actual results:
 the mouse cursor can't worked in the guest,the keyboard can worked.

Expected results:
 the mouse cursor can worked well in the guest

Additional info:
this issue only occur on windows guest with spice expect win2003,
linux guest with spice and win guest with vnc not happened.

Comment 2 Cole Robinson 2011-09-22 15:54:11 UTC
If you restart virt-manager does the mouse work? How about connecting to the guest with virt-viewer?

Comment 3 Cole Robinson 2011-09-22 15:54:35 UTC
Also how about VNC graphics vs. spice? Any difference?

Comment 4 zhe peng 2011-09-23 03:13:23 UTC
I re-test this, found only windows vm with spice multihead can reproduce this bug,
when restart virt-manager, the mouse can worked, virt-viewer not have this issue.

Comment 5 Cole Robinson 2011-09-27 15:22:01 UTC
Hmm, well since spice multihead isn't even exposed in the UI yet and it shouldn't be a common setup, this bug isn't very high priority. Deferring to 6.3

Comment 7 Cole Robinson 2011-12-09 22:35:36 UTC
Not urgent, and given reduced capacity for virt-manager/virtinst, just moving
this to the upstream tracker.

Comment 8 Cole Robinson 2013-08-17 15:04:12 UTC
My guess is this is a windows qxl or qemu issue. If anyone can still reproduce with latest versions of those I'd suggest filing a bug there.


Note You need to log in before you can comment on or make changes to this bug.