Bug 736969 - SELinux is preventing irqbalance from 'unix_read' accesses on the mémoire partagée Unknown.
Summary: SELinux is preventing irqbalance from 'unix_read' accesses on the mémoire par...
Keywords:
Status: CLOSED DUPLICATE of bug 736967
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b44bdcb5f70...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 08:08 UTC by panpan_du54
Modified: 2011-09-09 09:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 09:05:52 UTC


Attachments (Terms of Use)

Description panpan_du54 2011-09-09 08:08:05 UTC
SELinux is preventing irqbalance from 'unix_read' accesses on the mémoire partagée Unknown.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that irqbalance should be allowed unix_read access on the Unknown shm by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep irqbalance /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:irqbalance_t:s0
Target Context                system_u:system_r:initrc_t:s0
Target Objects                Unknown [ shm ]
Source                        irqbalance
Source Path                   irqbalance
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64
                              #1 SMP Fri Jul 29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   51
First Seen                    ven. 09 sept. 2011 05:28:24 CEST
Last Seen                     ven. 09 sept. 2011 10:04:44 CEST
Local ID                      6685fa08-b727-42f1-a595-803477e20741

Raw Audit Messages
type=AVC msg=audit(1315555484.2:2620): avc:  denied  { unix_read } for  pid=567 comm="irqbalance" key=839398080  scontext=system_u:system_r:irqbalance_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=shm


Hash: irqbalance,irqbalance_t,initrc_t,shm,unix_read

audit2allow

#============= irqbalance_t ==============
allow irqbalance_t initrc_t:shm unix_read;

audit2allow -R

#============= irqbalance_t ==============
allow irqbalance_t initrc_t:shm unix_read;

Comment 1 Miroslav Grepl 2011-09-09 09:05:52 UTC

*** This bug has been marked as a duplicate of bug 736967 ***


Note You need to log in before you can comment on or make changes to this bug.