Bug 736974 - SELinux is preventing NetworkManager from 'associate' accesses on the mémoire partagée Unknown.
Summary: SELinux is preventing NetworkManager from 'associate' accesses on the mémoire...
Keywords:
Status: CLOSED DUPLICATE of bug 736967
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3ab0b24f333...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 08:15 UTC by panpan_du54
Modified: 2011-09-09 09:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 09:06:43 UTC


Attachments (Terms of Use)

Description panpan_du54 2011-09-09 08:15:47 UTC
SELinux is preventing NetworkManager from 'associate' accesses on the mémoire partagée Unknown.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that NetworkManager should be allowed associate access on the Unknown shm by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep NetworkManager /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:system_r:initrc_t:s0
Target Objects                Unknown [ shm ]
Source                        NetworkManager
Source Path                   NetworkManager
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64
                              #1 SMP Fri Jul 29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   10
First Seen                    ven. 09 sept. 2011 09:02:37 CEST
Last Seen                     ven. 09 sept. 2011 10:08:14 CEST
Local ID                      a4372b9f-e26c-42cc-87c8-ab69006b3108

Raw Audit Messages
type=AVC msg=audit(1315555694.31:2630): avc:  denied  { associate } for  pid=564 comm="NetworkManager" key=839398080  scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=shm


Hash: NetworkManager,NetworkManager_t,initrc_t,shm,associate

audit2allow

#============= NetworkManager_t ==============
allow NetworkManager_t initrc_t:shm associate;

audit2allow -R

#============= NetworkManager_t ==============
allow NetworkManager_t initrc_t:shm associate;

Comment 1 Miroslav Grepl 2011-09-09 09:06:43 UTC

*** This bug has been marked as a duplicate of bug 736967 ***


Note You need to log in before you can comment on or make changes to this bug.