Bug 736976 - SELinux is preventing /usr/bin/python from using the 'signull' accesses on a process.
Summary: SELinux is preventing /usr/bin/python from using the 'signull' accesses on a ...
Keywords:
Status: CLOSED DUPLICATE of bug 736967
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:164c1740ea2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 08:19 UTC by panpan_du54
Modified: 2011-09-09 09:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 09:07:18 UTC


Attachments (Terms of Use)

Description panpan_du54 2011-09-09 08:19:36 UTC
SELinux is preventing /usr/bin/python from using the 'signull' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that python should be allowed signull access on processes labeled initrc_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep SetroubleshootF /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.
                              c1023
Target Context                system_u:system_r:initrc_t:s0
Target Objects                Unknown [ process ]
Source                        SetroubleshootF
Source Path                   /usr/bin/python
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           python-2.7.1-7.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64
                              #1 SMP Fri Jul 29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    ven. 09 sept. 2011 10:11:31 CEST
Last Seen                     ven. 09 sept. 2011 10:11:31 CEST
Local ID                      8b285db4-1f35-4160-9185-456c17598134

Raw Audit Messages
type=AVC msg=audit(1315555891.877:2643): avc:  denied  { signull } for  pid=14554 comm="SetroubleshootF" scontext=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=process


type=SYSCALL msg=audit(1315555891.877:2643): arch=x86_64 syscall=kill success=yes exit=0 a0=41c a1=0 a2=41c a3=7fff824d1100 items=0 ppid=14553 pid=14554 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=SetroubleshootF exe=/usr/bin/python subj=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 key=(null)

Hash: SetroubleshootF,setroubleshoot_fixit_t,initrc_t,process,signull

audit2allow

#============= setroubleshoot_fixit_t ==============
allow setroubleshoot_fixit_t initrc_t:process signull;

audit2allow -R

#============= setroubleshoot_fixit_t ==============
allow setroubleshoot_fixit_t initrc_t:process signull;

Comment 1 Miroslav Grepl 2011-09-09 09:07:18 UTC

*** This bug has been marked as a duplicate of bug 736967 ***


Note You need to log in before you can comment on or make changes to this bug.