Bug 736999 - dhcp's libdhcpctl libdst libomapi libraries need rebuilding with -fPIC
Summary: dhcp's libdhcpctl libdst libomapi libraries need rebuilding with -fPIC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Jiri Popelka
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-09 10:12 UTC by Alex Butcher
Modified: 2011-12-06 12:01 UTC (History)
2 users (show)

Fixed In Version: dhcp-4.1.1-23.P1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 12:01:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1597 normal SHIPPED_LIVE dhcp bug fix and enhancement update 2011-12-06 00:51:17 UTC

Description Alex Butcher 2011-09-09 10:12:20 UTC
Description of problem:

From the dhcp-4.1.1-12.P1.el6_0.4.src.rpm package changelog:
* Fri Nov 10 2006 David Cantrell <dcantrell@redhat.com> - 12:3.0.5-2
[...]
- Pass -fPIC instead of -fpie/-fPIE in compiler flags

From the dhcp.spec:
CFLAGS="%{optflags} -fno-strict-aliasing -fPIE -D_GNU_SOURCE" \

Building the libraries with -fPIE instead of -fPIC means they cannot be used to build Perl modules, for example.

Version-Release number of selected component (if applicable):

4.1.1-12.P1.el6_0.4

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 6 Jiri Popelka 2011-09-13 16:47:13 UTC
Alex, will you be willing to test new packages (architecture ?) to see whether
the problem is fixed in your environment ?

Comment 7 Alex Butcher 2011-09-14 09:38:27 UTC
Hi Jiri - sure, we can test. x86_64 is best for us, thanks.

Comment 8 Alex Butcher 2011-10-03 09:51:31 UTC
Sorry for the delay. I've passed it to a (busy) colleague for testing in his environment.

Comment 10 errata-xmlrpc 2011-12-06 12:01:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1597.html


Note You need to log in before you can comment on or make changes to this bug.