Bug 736999 - dhcp's libdhcpctl libdst libomapi libraries need rebuilding with -fPIC
dhcp's libdhcpctl libdst libomapi libraries need rebuilding with -fPIC
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On:
Blocks: 743047
  Show dependency treegraph
 
Reported: 2011-09-09 06:12 EDT by Alex Butcher
Modified: 2011-12-06 07:01 EST (History)
2 users (show)

See Also:
Fixed In Version: dhcp-4.1.1-23.P1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 07:01:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Butcher 2011-09-09 06:12:20 EDT
Description of problem:

From the dhcp-4.1.1-12.P1.el6_0.4.src.rpm package changelog:
* Fri Nov 10 2006 David Cantrell <dcantrell@redhat.com> - 12:3.0.5-2
[...]
- Pass -fPIC instead of -fpie/-fPIE in compiler flags

From the dhcp.spec:
CFLAGS="%{optflags} -fno-strict-aliasing -fPIE -D_GNU_SOURCE" \

Building the libraries with -fPIE instead of -fPIC means they cannot be used to build Perl modules, for example.

Version-Release number of selected component (if applicable):

4.1.1-12.P1.el6_0.4

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 6 Jiri Popelka 2011-09-13 12:47:13 EDT
Alex, will you be willing to test new packages (architecture ?) to see whether
the problem is fixed in your environment ?
Comment 7 Alex Butcher 2011-09-14 05:38:27 EDT
Hi Jiri - sure, we can test. x86_64 is best for us, thanks.
Comment 8 Alex Butcher 2011-10-03 05:51:31 EDT
Sorry for the delay. I've passed it to a (busy) colleague for testing in his environment.
Comment 10 errata-xmlrpc 2011-12-06 07:01:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1597.html

Note You need to log in before you can comment on or make changes to this bug.