Bug 737025 - Invalid output from pipe-menu
Summary: Invalid output from pipe-menu
Keywords:
Status: CLOSED DUPLICATE of bug 737112
Alias: None
Product: Fedora
Classification: Fedora
Component: openbox
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 11:52 UTC by Michael Schwendt
Modified: 2012-01-10 18:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 18:33:37 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2011-09-09 11:52:32 UTC
Description of problem: Browsing Openbox's context menu creates empty submenus and opens many error dialogs when opening the empty submenus, such as:

| Openbox
|
| Invalid output from pipe-menu
| "/usr/libexec/openbox-xdg-menu /etc/xdg/openbox/applications"


Version-Release number of selected component (if applicable):
$ rpm -qa openbox\*
openbox-libs-3.5.0-1.fc16.x86_64
openbox-3.5.0-1.fc16.x86_64


How reproducible:
Always, also with a fresh user account.

Steps to Reproduce:
1. At gdm, log in to a fresh Openbox session.
2. Browse Openbox's context menu.
  
Actual results:
Error dialogs open for the submenus, and they are empty.


Expected results:
Have apps and tools listed in the submenus.

Comment 1 Christoph Wickert 2011-09-09 18:33:37 UTC
As this is the cause for bug 737112, let's close it DUPLICATE.

*** This bug has been marked as a duplicate of bug 737112 ***

Comment 2 Brendan Jones 2012-01-10 18:05:10 UTC
I also had this error due to a wine desktop file, although one tha twas validly installed:

wine-Programs-Caché-CACHE-Launcher.menu

Note the "é"

Removing the offending entry from .config/menus/applications-merged/ fixed it


Note You need to log in before you can comment on or make changes to this bug.