Bug 737092 - cloning repo fails with index out of range
Summary: cloning repo fails with index out of range
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 15:26 UTC by Preethi Thomas
Modified: 2013-09-09 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 17:54:45 UTC


Attachments (Terms of Use)

Description Preethi Thomas 2011-09-09 15:26:26 UTC
Description of problem:
[root@preethi ~]# pulp-admin repo clone --id=pulp --clone_id=pulp-clone --clone_name=pulp-clone --feed=origin --relativepath=/pulp-clone1/ -F
Repository [pulp] is being cloned as [pulp-clone]
Clone: Error
Item Details: 
Rpms: 16/16
Traceback (most recent call last):
  File "/usr/bin/pulp-admin", line 23, in <module>
    admin.main()
  File "/usr/lib/python2.7/site-packages/pulp/client/lib/cli.py", line 152, in main
    command.main(self.args[1:])
  File "/usr/lib/python2.7/site-packages/pulp/client/pluginlib/command.py", line 129, in main
    action.main(args[1:])
  File "/usr/lib/python2.7/site-packages/pulp/client/pluginlib/command.py", line 211, in main
    self.run()
  File "/usr/lib/python2.7/site-packages/pulp/client/admin/plugins/repo.py", line 609, in run
    self.clone_foreground(task)
  File "/usr/lib/python2.7/site-packages/pulp/client/admin/plugins/repo.py", line 582, in clone_foreground
    raise SyncError(task['traceback'][-1])
repo.SyncError: IndexError: tuple index out of range

[root@preethi ~]# 
[root@preethi ~]# 


Version-Release number of selected component (if applicable):
root@preethi ~]# rpm -q pulp
pulp-0.0.230-3.fc15.noarch

Comment 1 Preethi Thomas 2011-09-09 17:54:45 UTC
Looks like this just happened on this box. Couldn't reproduce it again on another box

[root@pulp-f15 ~]# pulp-admin -u admin -p admin repo clone --id=pulp1 --clone_id=pulp-clone1 --clone_name=pulp-clone1 --feed=origin -F
Repository [pulp1] is being cloned as [pulp-clone1]
Clone: Finished
Item Details: 
Rpms: 15/15

[root@pulp-f15 ~]# rpm -q pulp
pulp-0.0.230-3.fc15.noarch
[root@pulp-f15 ~]#


Note You need to log in before you can comment on or make changes to this bug.