Bug 737110 - Wrong InputSlot group proposed for HP Photosmart Pro B8850
Summary: Wrong InputSlot group proposed for HP Photosmart Pro B8850
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 15
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 16:17 UTC by info@kobaltwit.be
Modified: 2011-11-16 15:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-16 15:50:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 891208 None None None Never

Description info@kobaltwit.be 2011-09-09 16:17:58 UTC
Description of problem:
I have a HP Photosmart Pro B8850 installed and configured using cups and the hpcups driver. When printing with this setup, cups presents the following set of Input Slots:
* Auto-Select
* Photo Tray
* Upper Tray
* Lower Tray
* Envelope Feeder
* Large Capacity Tray
* Manual Feeder
* Multi Purpose Tray
* CD or DVD Tray

This makes no sense however, because the printer only has two input trays:
* Main tray
* Specialty media tray

See
http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01313765&cc=us&dlc=en&lc=en&jumpid=reg_R1002_USEN for the printer specs.

Version-Release number of selected component (if applicable):
cups-1.4.8-1.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1. Install the above printer
2. Check the Input tray options that come by default with cups
  
Actual results:
It shows a multitude trays that don't exist on the device and can't be added either.

Expected results:
Display only the two available trays.

Additional info:
You can also refer to this thread on HPLIP launchpad: https://answers.launchpad.net/hplip/+question/105443
The sixth comment on that thread shows what the InputSlot section in the ppd file for this printer should be.

Comment 1 info@kobaltwit.be 2011-09-09 16:19:25 UTC
As an additional point of information, I can add that the cups webinterface lists the used driver for this printer as
hpcups 3.11.5

Comment 2 Tim Waugh 2011-11-16 15:50:41 UTC
Reported upstream.


Note You need to log in before you can comment on or make changes to this bug.