Bug 737114 - Dirsrv admin console password does not accept special characters.
Summary: Dirsrv admin console password does not accept special characters.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Admin
Version: 7.1
Hardware: i386
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 16:25 UTC by Clinton Popovich
Modified: 2015-01-04 23:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Linux threat03 2.6.18-194.17.1.el5PAE #1 SMP Wed Sep 29 13:31:51 EDT 2010 i686 i686 i386 GNU/Linux Aug 02 14:39:29 Installed: centos-ds-base-8.1.0-0.14.el5.centos.2.i386 Aug 02 14:39:30 Installed: centos-ds-admin-8.1.0-9.el5.centos.1.i386 Aug 02 14:39:30 Installed: jss-4.2.5-1.el5.centos.1.i386 Aug 02 14:39:30 Installed: idm-console-framework-1.1.3-9.el5.centos.2.noarch Aug 02 14:39:30 Installed: centos-idm-console-1.0.1-1.el5.centos.2.i386 Aug 02 14:39:32 Installed: centos-admin-console-8.1.0-2.el5.centos.2.noarch Aug 02 14:39:32 Installed: centos-ds-console-8.1.0-5.el5.centos.2.noarch Aug 02 14:39:32 Installed: centos-ds-8.1.0-1.el5.centos.2.i386 Aug 05 10:52:32 Installed: centos-ds-sslsetup-1.0.0-3.el5.nx.noarch Aug 11 11:29:27 Installed: openldap-clients-2.3.43-12.el5_6.7.i386
Last Closed: 2011-09-20 20:19:16 UTC


Attachments (Terms of Use)

Description Clinton Popovich 2011-09-09 16:25:14 UTC
Aug 02 14:39:29 Installed: centos-ds-base-8.1.0-0.14.el5.centos.2.i386
Aug 02 14:39:30 Installed: centos-ds-admin-8.1.0-9.el5.centos.1.i386
Aug 02 14:39:30 Installed: jss-4.2.5-1.el5.centos.1.i386
Aug 02 14:39:30 Installed: idm-console-framework-1.1.3-9.el5.centos.2.noarch
Aug 02 14:39:30 Installed: centos-idm-console-1.0.1-1.el5.centos.2.i386
Aug 02 14:39:32 Installed: centos-admin-console-8.1.0-2.el5.centos.2.noarch
Aug 02 14:39:32 Installed: centos-ds-console-8.1.0-5.el5.centos.2.noarch
Aug 02 14:39:32 Installed: centos-ds-8.1.0-1.el5.centos.2.i386
Aug 05 10:52:32 Installed: centos-ds-sslsetup-1.0.0-3.el5.nx.noarch
Aug 11 11:29:27 Installed: openldap-clients-2.3.43-12.el5_6.7.i386


Steps to reproduce:
1) Install dirsrv
2) enter admin console
3) expand server group and double click on "Administration Server"
4) Click "Configuration" tab
5) Click "Access" tab
6) reset password utilizing an ! as the last character ( I used an 8 character password)
7) try to login again with new password.

Comment 1 Nathan Kinder 2011-09-20 17:47:30 UTC
I am unable to reproduce this using current builds on F14.  I first performed an initial install with an admin password ending in '!'.  The install was successful, and I was able to log in via 389-console as the admin user.  I then changed the admin password via the "Access" tab in 389-console, with the new password also ending with '!'.  This password change was successful, and I was able to log into 389-console as the admin user using this new password.

The version of 389 that you are using is fairly old.  You might want to try a more recent version to see if it works properly for you.


Note You need to log in before you can comment on or make changes to this bug.