Bug 73714 - [RFE] gui showall
[RFE] gui showall
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 05:57 EDT by Gene Czarcinski
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 15:42:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-09-09 05:57:33 EDT
Description of Problem:
Although the up2date-nox has a showall function, there is none for the gui
version/  Add this capability.
Comment 1 Gene Czarcinski 2002-09-09 06:00:39 EDT
This report is related to bugzilla report 73715
Comment 2 Adrian Likins 2003-08-06 18:44:09 EDT
see 73715

--show-package-dialog as a commandline option
will enable an extra screen showing all available packages now.

Should be there in rh9 or later.
Comment 3 Gene Czarcinski 2003-10-27 14:04:26 EST
--show-package-dialog does not appear to work

FC1-T3 (up2date 4.1.11-3)
Comment 4 Adrian Likins 2003-10-27 20:32:58 EST
seems to be working here with .12 (and nothing related to that should
of changed recently).

What behaviour are you seeing?

expected behaviour is that after show the skipped packages screen,
and the packages needing to be updated screen, it will show a screen
showing all the packages available that are not currently installed. 
Comment 5 Gene Czarcinski 2003-10-28 04:26:13 EST
OK, my systems are FC1-T3 and are current with rawhide.  When I run with
--show-package-dialog (started from a root terminal), I get the regular up2date
first panel which I proceed through.  When it finishes download information from
rawhide, I get a "Your systems is fully updated.  No new packages are needed."
popup with an OK button.  When I hit the OK button, up2date terminates.
Comment 6 Gene Czarcinski 2003-10-28 09:34:09 EST
OK, I now see that it is partially working.  IF you have updates available for
installed packages, then you are offered a second panel with additional packages
to install.  However, if you do not have any installed package updates
available, then it kicks out "early" and you never see the second selection
panel.  You need to select at least one update on the first selection panel.
Comment 7 Gene Czarcinski 2003-10-28 09:36:32 EST
Correction -- you do not need to select an updat the get the second panel ...
but there must be updates.
Comment 8 Adrian Likins 2003-10-28 12:27:32 EST
hmm, i'll have to look at it again. But it's supposed to always
show that screen, regardless if you selected any updates or
had any updates or not. If thats not what it's doing, its
busted. 
Comment 9 Gene Czarcinski 2003-10-28 12:40:43 EST
I tried this on three different systems.  While two of these have been "mucked
with", the third (laptop) has not been touched since FC1-T3 was installed.

In all cases, if there where no updates, then I got kicked out early.  If there
were updates, then even if I did not select any, I got the additional panel.

I was using the latest up2date (4.1.12-1).

Note You need to log in before you can comment on or make changes to this bug.