Bug 73726 - konsole and gnome-terminal screen update slow
konsole and gnome-terminal screen update slow
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 12:21 EDT by Stephen Lawrence Jr.
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 02:57:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Lawrence Jr. 2002-09-09 12:21:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
I have tried konsole, and gnome-terminal, and both have extremely slow screen
updating, especially in 'ls' or 'ps', or 'cat' type commands.

Running xterm works fine.

I suspect it has something to do with the anti-aliasing being done?

Version-Release number of selected component (if applicable):
gnome-terminal-2.0.1-2
kdebase-3.0.3-3

How reproducible:
Always

Steps to Reproduce:
1.open konsole and gnome-terminal
2.'cat /var/log/messages'
3. Open xterm
4. 'cat /var/log/messages'


Actual Results:  Notice the slow window update under konsole and gnome-terminal
Notice that xterm performs normally.

Additional info:
Comment 1 Mike A. Harris 2002-09-09 23:11:41 EDT
Not an XFree86 bug.  Reassigning to gnome-terminal since it was listed as
being slow.
Comment 2 Stephen Lawrence Jr. 2002-09-09 23:45:42 EDT
This problem is also evident in KDE's konsole terminal. And it shows up when in
either GNOME or KDE desktop.
Comment 3 Need Real Name 2002-11-19 13:00:28 EST
I am having a similar problem except for me, konsole, gnome-terminal, and xterm
are all slow.  For me xterm is extremely slow.  When I issue the command:

ls -l /dev

it takes 42 seconds for xterm to finish the directory listing under KDE.  Under
gnome, the same command took 2:40 to complete in xterm.  When I'm not running
X-windows, the same command takes less than two seconds to complete from the
console.  From konsole, the same command took 24 seconds and from gnome-terminal
it took 16 seconds.  I do not believe this is a problem with konsole
or gnome-terminal since it happens in both and I've had the problem xterm too.

When I run top while running the command, X is using the majority of the CPU.

FYI, it may or may not be related... the computer that I'm having this problem
with is one of the computers for which X stopped installing correctly between
versions 7.2 and 7.3 due to support for S3 968 video controllers.  It still
didn't install correctly in redhat8, but I used the generic vesa driver as
recommended in response to my bug report #65629.
Comment 4 Havoc Pennington 2002-11-19 14:09:34 EST
Using the generic vesa driver you won't have hardware acceleration,
which probably means pretty much everything is going to be slow 
to some degree. X using most of the CPU suggests that's the problem.
Comment 5 will smith 2004-08-04 15:23:06 EDT
Try using 'xterm -j -s' which enables 'jump scrolling'.  Works for me.
 gnome-terminal should really get this feature.
Comment 6 Breght Boschker 2004-08-20 03:42:23 EDT
I was experiencing the same problems with Konsole. I have changed the
font from 'Monospaced' to MiscFixed which gives a considerable speed
improvement.
Comment 7 Warren Togami 2005-03-29 02:57:19 EST
old

Note You need to log in before you can comment on or make changes to this bug.