Bug 737288 - [Arrandale] 16 alpha, beta tc1,2 xorg intel black screen cannot install
[Arrandale] 16 alpha, beta tc1,2 xorg intel black screen cannot install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-10 13:05 EDT by Reartes Guillermo
Modified: 2013-02-13 02:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 02:58:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg, fc16 beta tc2 (123.13 KB, text/plain)
2011-09-13 11:35 EDT, Reartes Guillermo
no flags Details
messages, fc16 beta tc2 (83.79 KB, text/plain)
2011-09-13 11:37 EDT, Reartes Guillermo
no flags Details
xorg, fc16 beta tc2 (27.32 KB, text/plain)
2011-09-13 11:37 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2011-09-10 13:05:19 EDT
Description of problem:

The F16 alpha does boot only in basic video. 
Basic video has its separate problems/issues.

The beta-tc1 does only boot in basic video.
Basic video has its separate problems.

The beta-tc2 raches kdm login screen, but it is all black 
(only the pointer is shown).
CTRL+ALT+BACKSPACE kills X, it restarts, KDM is shown, after 
hitting enter (livecdusr has no passwd)
it starts loading KDE, but the screen does not change, istead of 
black, it is the KDM login at the moment of the ENTER key.

switching to another vt is not possible (or it happens and the screen does not change...)

Video:
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)


Version-Release number of selected component (if applicable):
Fedora 16 beta tc2

How reproducible:
allways

Steps to Reproduce:
1. boot the livecd kde
  
Actual results:
cannot reach the installer.

Expected results:
be able to install and test f16


Additional info:
Comment 1 Matěj Cepl 2011-09-12 07:57:57 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, get to the kdm login screen, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log*; check with grep Backtrace /var/log/Xorg* which logs might be the most interesting ones, send us at least Xorg.0.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Reartes Guillermo 2011-09-13 11:34:36 EDT
* The Xorg session is using vt2 istead of vt1 (or vt7 in old-style)

* There are SELinux AVCs in /tmp and /run

I booted normally and reached kdm login, then:

grabbed a dmesg, messages and xorg.0.log (with debug=0x04).

* i was not able to use an usb key because it did not show up when plugged. was able to manually load usb-storage but it was still not detected by the kernel, it did not blink and it did not show up in lsubs also. So, no usb in the livecd.

set selinux to permissive
killed X with ctrl+alt+backspace
logged in, waited until it loaded

swtiched to vt3, then to vt2, started to enable wifi

then after many cycles of vt3>vt2>vt3 i was able to get the files over wifi.

also note that some elements did update (the nm window worked, but the rest of the desktop was still).
Comment 3 Reartes Guillermo 2011-09-13 11:35:25 EDT
Created attachment 522949 [details]
dmesg, fc16 beta tc2
Comment 4 Reartes Guillermo 2011-09-13 11:37:02 EDT
Created attachment 522950 [details]
messages, fc16 beta tc2
Comment 5 Reartes Guillermo 2011-09-13 11:37:52 EDT
Created attachment 522951 [details]
xorg, fc16 beta tc2
Comment 6 Reartes Guillermo 2011-09-13 11:41:25 EDT
Also note than when booted with selinux in enforcing mode (default), after kdm there is an error box "unable to save bookmarks in /home/liveuser/.local/share/user-places[...]" i took a picture but it is has some blur (and it was helped by the fact that the backlight does whatever it wants with its own brightness (also in f15)).
So i set permissive mode.
Comment 7 Reartes Guillermo 2012-06-02 16:56:45 EDT
This bureport should be closed because:

F16 (Release) Can be installed correcly from live-cd on the same system.
F17 (Release) Live-CD can boot ok.

This bugreport was opened agains a pre-release version of F16.

Please close this bugreport.
Comment 8 Reartes Guillermo 2012-07-10 16:02:07 EDT
Please close this bugreport, it was created agains F16 alpha and the issue is fixed a long time ago.
Comment 9 Reartes Guillermo 2012-08-13 08:25:34 EDT
Please close this bug-report as per comment #8.
Comment 10 Fedora End Of Life 2013-01-16 04:56:58 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Fedora End Of Life 2013-02-13 02:58:41 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.