Bug 737326 - Cannot enter data in template data table
Summary: Cannot enter data in template data table
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor)
Version: BRMS 5.2.0-ER1
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Tihomir Surdilovic
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 06:40 UTC by Jeff Slone
Modified: 2011-09-15 05:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 20:14:21 UTC
Type: ---


Attachments (Terms of Use)
Screenshot showing what double-clicking a cell in the data table does... (7.58 KB, image/png)
2011-09-11 06:40 UTC, Jeff Slone
no flags Details

Description Jeff Slone 2011-09-11 06:40:19 UTC
Created attachment 522591 [details]
Screenshot showing what double-clicking a cell in the data table does...

Description of problem: When creating a template rule in Gunvor 5.2 ER3, you cannot enter data into the data table. When you double-click a cell, it places a sorting arrow in the cell. You cannot enter any data in the table. See the attached screen shot.

This is directly related to the other bug I filed on the decision table editor: https://bugzilla.redhat.com/show_bug.cgi?id=737317

Version-Release number of selected component (if applicable):
BRMS (Guvnor) 5.2 ER3

How reproducible:
Always

Steps to Reproduce:
1. Author a rule template in BRMS 5.2 ER3.
2. Click Load Template Data.
3. Double-click any of the cells. No data entry dialog pops-up. Instead a sorting arrow is placed in the cell. 
  
Actual results:
No data can be entered in a rule template.

Expected results:
You should be able to enter data into the rule template data table. 

Additional info:

Comment 1 manstis 2011-09-13 15:02:42 UTC
You need to add rows of data first. I suspect you are clicking in the header
(where the "sort" icons reside). There is a "Add row" button on an empty grid;
after which rows can be inserted arbitrarily using the "+" icon on the side.

Comment 2 Jeff Slone 2011-09-13 17:56:57 UTC
The add row button doesn't work either. Please test this again. You cannot add rows or add data to the table. If you need me to post an entire repo I will.

Comment 3 manstis 2011-09-14 07:54:21 UTC
Hi Jeff, I re-tried with the 5.2.x branch in github (that I believe Guvnor 5.2 ER3 is based on) and was able to add rows using both the "Add row" button and the "+" symbol in the LHS (once one row has been added). Please can you supply a copy of the test repo you are using - incase there is a bug caused by your particular data? Thanks. Mike

Comment 4 Jeff Slone 2011-09-14 20:14:21 UTC
Apparently this is something specific on my RHEL 6 laptop (video driver, patch version...I don't know). I tested it in the RHEL 5 classroom image and it works fine so I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.