Bug 73743 - kernel install script segfaults grubby
kernel install script segfaults grubby
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 17:54 EDT by Curtis Doty
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-09 18:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curtis Doty 2002-09-09 17:54:59 EDT
# rpm -ivh kernel-2.4.18-14.i686.rpm        
warning: kernel-2.4.18-14.i686.rpm: Header V3 DSA signature: NOKEY, key ID 
897da07a
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
/sbin/new-kernel-pkg: line 249:  2133 Segmentation fault      /sbin/grubby --
add-kernel=$bootPrefix/vmlinuz-$version $INITRD --copy-default --title 
$version --args="root=$rootdevice" --remove-kernel="TITLE=$version" --lilo

I've lilo with no grub. Could this be due to a lilo.conf that confuses grubby?

boot=/dev/sda
map=/boot/map
install=/boot/boot.b
linear
read-only

prompt
timeout=50
message=/boot/message
vga=ask

default=linux
append="root=LABEL=/"

image=/boot/vmlinuz-2.4.18-12.5
        label=linux
        initrd=/boot/initrd-2.4.18-12.5.img

If so, this is bug in mkinitrd package...just manifests itself here.
Comment 1 Jeremy Katz 2002-11-06 17:12:55 EST
This looks fixed with the final release.  Reopen if this isn't the case.

Note You need to log in before you can comment on or make changes to this bug.